Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Linux system security checks" |
| 2 | DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used." |
| 3 | SECTION = "security" |
| 4 | LICENSE = "BSD" |
| 5 | HOMEPAGE="https://github.com/slimm609/checksec.sh" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=93fddcca19f6c897871f9b5f9a035f4a" |
| 8 | |
Brad Bishop | 49e29a1 | 2019-09-01 15:21:06 -0400 | [diff] [blame] | 9 | SRCREV = "04582bad41589ad479ca8b1f0170ed317475b5a5" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | SRC_URI = "git://github.com/slimm609/checksec.sh" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | do_install() { |
| 15 | install -d ${D}${bindir} |
| 16 | install -m 0755 ${S}/checksec ${D}${bindir} |
| 17 | } |
| 18 | |
Brad Bishop | 49fa52d | 2019-10-16 14:23:15 -0400 | [diff] [blame] | 19 | RDEPENDS_${PN} = "bash openssl-bin binutils" |