blob: 9d73da90d87c1e7b7a6a38f96f0f662357648d06 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc"
2HOMEPAGE = "https://github.com/cminyard/gensio"
3LICENSE = "GPL-2.0 & LGPL-2.1"
4LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \
5 file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \
6 "
7
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05008SRCREV = "998a017076a86179696a3ad811e2bae9155e46cb"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10SRC_URI = "git://github.com/cminyard/gensio;protocol=https \
Andrew Geissler82c905d2020-04-13 13:39:40 -050011 "
12
13S = "${WORKDIR}/git"
14
15inherit autotools
16
17PACKAGECONFIG ??= "openssl tcp-wrappers"
18
19PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl"
20PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers"
21PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig"
22
23EXTRA_OECONF = "--without-python"
24
25RDEPENDS_${PN} += "bash"