blob: a1e94527672c3cbefdb912de720243c7dd7ab2c0 [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Parse strings using a specification based on the Python format() syntax"
2HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
3LICENSE = "MIT"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05005
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05006SRC_URI[md5sum] = "ba263b3143e9528ae960bbba4d56bf25"
7SRC_URI[sha256sum] = "cd89e57aed38dcf3e0ff8253f53121a3b23e6181758993323658bffc048a5c19"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05008
9inherit pypi setuptools3 ptest
10
11RDEPENDS_${PN} += "\
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-logging \
14 "
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20RDEPENDS_${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/
26}