blob: 66c05a1ff18a7a430b8e2a9aba2a101d73e0fce9 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5GNOMEBASEBUILDCLASS = "meson"
6
7DEPENDS = " \
8 libxml2-native \
9 gtk4 \
10 mutter \
11 evolution-data-server \
12 gcr \
13 geocode-glib \
14 gjs \
15 gnome-autoar \
16 polkit \
17 libcroco \
18 libsoup-3.0 \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', 'startup-notification', d)} \
20 ibus \
21 gsettings-desktop-schemas \
22"
23
24inherit gnomebase gsettings gettext gobject-introspection gtk-icon-cache features_check bash-completion
25
26REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
27
28GTKIC_VERSION = "4"
29GTKDOC_MESON_OPTION = "gtk_doc"
30GIR_MESON_OPTION = ""
31
32# gobject-introspection is mandatory and cannot be configured
33REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
34
Andrew Geissler220dafd2023-10-04 10:18:08 -050035SRC_URI[archive.sha256sum] = "3cabe40bdd4e379c7082b39ffa45b8bef5c9cf86408fb0d836e1571c443217cd"
Andrew Geissler517393d2023-01-13 08:55:19 -060036SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch"
37
38PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
39PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
40PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false,networkmanager,networkmanager"
41PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
42
43EXTRA_OEMESON = " \
44 -Dgjs_path=${bindir}/gjs \
45 -Dextensions-app:gjs_path=${bindir}/gjs \
46 -Dtests=false \
47 -Dman=false \
Andrew Geissler517393d2023-01-13 08:55:19 -060048"
49
50do_install:append() {
51 # fix shebangs
52 for tool in `find ${D}${bindir} -name '*-tool'`; do
53 sed -i 's:#!${PYTHON}:#!${bindir}/${PYTHON_PN}:' $tool
54 done
55}
56
57GSETTINGS_PACKAGE = "${PN}-gsettings"
58
59FILES:${PN} += " \
60 ${datadir}/metainfo \
61 ${datadir}/dbus-1 \
62 ${datadir}/gnome-control-center \
63 ${datadir}/xdg-desktop-portal \
64 ${systemd_user_unitdir} \
65"
66
67RDEPENDS:${PN} += " \
68 accountsservice \
69 adwaita-icon-theme \
70 adwaita-icon-theme-cursors \
71 gdm-base \
72 gnome-control-center \
73 gnome-backgrounds \
74 gnome-bluetooth \
75 gnome-desktop \
76 gnome-session \
77 gnome-settings-daemon \
78 gnome-shell-gsettings \
79 gsettings-desktop-schemas \
80 librsvg-gtk \
81"
82
83PACKAGES =+ "${PN}-tools ${PN}-gsettings"
84FILES:${PN}-tools = "${bindir}/*-tool"
85RDEPENDS:${PN}-tools = "python3-core"
86