Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \ |
| 2 | block devices. It has a plugin-based architecture where each technology (like \ |
| 3 | LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \ |
| 4 | with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)." |
| 5 | HOMEPAGE = "http://rhinstaller.github.io/libblockdev/" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 6 | LICENSE = "LGPL-2.0-or-later" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | SECTION = "devel/lib" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c" |
| 10 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 11 | inherit autotools gobject-introspection pkgconfig lib_package |
| 12 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 13 | DEPENDS = "autoconf-archive-native glib-2.0 kmod udev libnvme" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 15 | SRC_URI = "git://github.com/storaged-project/libblockdev;branch=master;protocol=https \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 16 | " |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 17 | SRCREV = "38378931d285b91333ff2e2a391b1fe91072f9bb" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
| 19 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 20 | FILES:${PN} += "${libdir}/python3.*/site-packages" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 22 | PACKAGECONFIG ??= "python3 lvm lvm-dbus dm parted fs escrow btrfs crypto mdraid mpath nvdimm tools" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2" |
| 25 | PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2" |
| 26 | PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | PACKAGECONFIG[parted] = "--with-part, --without-part, parted" |
| 28 | PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux" |
| 29 | PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native" |
| 30 | PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key" |
| 32 | PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools" |
| 33 | PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key" |
| 34 | PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 35 | PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2" |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 36 | PACKAGECONFIG[tools] = "--with-tools,--without-tools,libbytesize libdevmapper" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | |
| 38 | export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs" |