Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Bash Automated Testing System" |
| 2 | DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \ |
| 3 | provides a simple way to verify that the UNIX programs you write behave as expected." |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 4 | HOMEPAGE = "https://github.com/bats-core/bats-core" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b" |
| 7 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 8 | SRC_URI = "\ |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 9 | git://github.com/bats-core/bats-core.git;branch=master;protocol=https \ |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 10 | " |
| 11 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 12 | # v1.10.0 |
| 13 | SRCREV = "f7defb94362f2053a3e73d13086a167448ea9133" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 17 | # Numerous scripts assume ${baselib} == lib, which is not true. |
| 18 | # |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 19 | do_configure:prepend() { |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 20 | for f in ${S}/libexec/bats-core/* ${S}/lib/bats-core/* ; do |
| 21 | sed -i 's:\$BATS_ROOT/lib/:\$BATS_ROOT/${baselib}/:g' $f |
| 22 | done |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 23 | } |
| 24 | |
| 25 | do_install() { |
| 26 | # Just a bunch of bash scripts to install |
| 27 | ${S}/install.sh ${D}${prefix} ${baselib} |
| 28 | } |
| 29 | |
| 30 | RDEPENDS:${PN} = "bash" |
| 31 | FILES:${PN} += "${libdir}/bats-core/*" |
| 32 | |
| 33 | PACKAGECONFIG ??= "pretty" |
| 34 | PACKAGECONFIG[pretty] = ",,,ncurses" |