blob: d2a93e190b75d9b33509f3ca5026d2c71262872b [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Bash Automated Testing System"
2DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
3provides a simple way to verify that the UNIX programs you write behave as expected."
Andrew Geissler9aee5002022-03-30 16:27:02 +00004HOMEPAGE = "https://github.com/bats-core/bats-core"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
7
Andrew Geisslerd5838332022-05-27 11:33:10 -05008SRC_URI = "\
Andrew Geissler615f2f12022-07-15 14:00:58 -05009 git://github.com/bats-core/bats-core.git;branch=master;protocol=https \
Andrew Geisslerd5838332022-05-27 11:33:10 -050010 "
11
Patrick Williams2a254922023-08-11 09:48:11 -050012# v1.10.0
13SRCREV = "f7defb94362f2053a3e73d13086a167448ea9133"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014
15S = "${WORKDIR}/git"
16
Patrick Williamse760df82023-05-26 11:10:49 -050017# Numerous scripts assume ${baselib} == lib, which is not true.
18#
Andrew Geissler9aee5002022-03-30 16:27:02 +000019do_configure:prepend() {
Patrick Williamse760df82023-05-26 11:10:49 -050020 for f in ${S}/libexec/bats-core/* ${S}/lib/bats-core/* ; do
21 sed -i 's:\$BATS_ROOT/lib/:\$BATS_ROOT/${baselib}/:g' $f
22 done
Andrew Geissler9aee5002022-03-30 16:27:02 +000023}
24
25do_install() {
26 # Just a bunch of bash scripts to install
27 ${S}/install.sh ${D}${prefix} ${baselib}
28}
29
30RDEPENDS:${PN} = "bash"
31FILES:${PN} += "${libdir}/bats-core/*"
32
33PACKAGECONFIG ??= "pretty"
34PACKAGECONFIG[pretty] = ",,,ncurses"