Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame^] | 1 | SUMMARY = "Snowball compiler and stemming algorithms" |
| 2 | HOMEPAGE = "https://snowballstem.org/" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2750797da77c1d784e7626b3f7d7ff3e" |
| 5 | |
| 6 | DEPENDS_class-target = "${BPN}-native" |
| 7 | |
| 8 | SRC_URI = "\ |
| 9 | git://github.com/snowballstem/snowball.git \ |
| 10 | file://0001-Build-so-lib.patch \ |
| 11 | file://0002-snowball-stemwords-do-link-with-LDFLAGS-set-by-build.patch \ |
| 12 | " |
| 13 | SRCREV = "c70ed64f9d41c1032fba4e962b054f8e9d489a74" |
| 14 | S = "${WORKDIR}/git" |
| 15 | PV = "2.0.0" |
| 16 | LIBVER = "0.0.0" |
| 17 | |
| 18 | inherit lib_package |
| 19 | |
| 20 | BBCLASSEXTEND = "native" |
| 21 | |
| 22 | do_compile_prepend_class-target() { |
| 23 | # use native tools |
| 24 | sed -i 's:./snowball :snowball :g' ${S}/GNUmakefile |
| 25 | } |
| 26 | |
| 27 | do_install() { |
| 28 | install -d ${D}${bindir} |
| 29 | install -m 755 ${S}/snowball ${D}${bindir} |
| 30 | install -m 755 ${S}/stemwords ${D}${bindir} |
| 31 | |
| 32 | install -d ${D}${libdir} |
| 33 | install -m 755 ${S}/libstemmer.so.${LIBVER} ${D}${libdir}/ |
| 34 | ln -s libstemmer.so.${LIBVER} ${D}${libdir}/libstemmer.so.0 |
| 35 | ln -s libstemmer.so.${LIBVER} ${D}${libdir}/libstemmer.so |
| 36 | |
| 37 | install -d ${D}${includedir} |
| 38 | install -m 644 ${S}/include/*.h ${D}${includedir} |
| 39 | } |