Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Berkeley TestFloat is a small collection of programs for \ |
| 2 | testing that an implementation of binary floating-point conforms to the \ |
| 3 | IEEE Standard for Floating-Point Arithmetic." |
| 4 | |
| 5 | HOMEPAGE = "http://www.jhauser.us/arithmetic/TestFloat.html" |
| 6 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame^] | 7 | LICENSE = "BSD-3-Clause" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://TestFloat-${PV}/COPYING.txt;md5=e45c175a323b5727777fb6bd4b26eafc" |
| 9 | |
| 10 | SRC_URI = "\ |
| 11 | http://www.jhauser.us/arithmetic/TestFloat-3a.zip;name=TestFloat \ |
| 12 | http://www.jhauser.us/arithmetic/SoftFloat-3a.zip;name=SoftFloat \ |
| 13 | file://0001-Makefile-for-cross-compile-SoftFloat.patch \ |
| 14 | file://0002-Makefile-for-cross-compile-TestFloat.patch \ |
| 15 | " |
| 16 | SRC_URI[TestFloat.md5sum] = "5a124e85ab74c5e52da27d401cea6cc3" |
| 17 | SRC_URI[TestFloat.sha256sum] = "fa258b5b3c751656a372051adee4183e19ad4763032322eb7a87dfb9e2c22c75" |
| 18 | SRC_URI[SoftFloat.md5sum] = "e53bd4550cf99690642c41374d188517" |
| 19 | SRC_URI[SoftFloat.sha256sum] = "946fd23180559d60eb6683dda1cf8b142f5426dedfefb97b03c6afdfd70ee9e0" |
| 20 | |
| 21 | S = "${WORKDIR}" |
| 22 | |
| 23 | do_compile(){ |
| 24 | oe_runmake -C SoftFloat-${PV}/build/Linux-Cross-Compile/ |
| 25 | oe_runmake -C TestFloat-${PV}/build/Linux-Cross-Compile/ |
| 26 | } |
| 27 | |
| 28 | do_install(){ |
| 29 | install -d ${D}/${bindir} |
| 30 | install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testfloat ${D}/${bindir} |
| 31 | install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testfloat_gen ${D}/${bindir} |
| 32 | install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testfloat_ver ${D}/${bindir} |
| 33 | install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/testsoftfloat ${D}/${bindir} |
| 34 | install ${S}/TestFloat-${PV}/build/Linux-Cross-Compile/timesoftfloat ${D}/${bindir} |
| 35 | } |