Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 1 | SUMMARY = "user and group account administration library" |
| 2 | DESCRIPTION = "The libuser library implements a standardized interface for manipulating and administering user \ |
| 3 | and group accounts" |
| 4 | HOMEPAGE = "https://pagure.io/libuser" |
| 5 | BUGTRACKER = "https://pagure.io/libuser/issues" |
| 6 | |
| 7 | LICENSE = "LGPL-2.0-only" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ |
| 9 | file://lib/user.h;endline=19;md5=76b301f63c39fa992062395efbdc9558 \ |
| 10 | file://samples/testuser.c;endline=19;md5=3b87fa660fa3f4a6bb31d624afe30ba1" |
| 11 | |
| 12 | SECTION = "base" |
| 13 | |
| 14 | SRC_URI = "https://releases.pagure.org/libuser/libuser-${PV}.tar.xz \ |
| 15 | file://0001-docs-Disable-building.patch \ |
| 16 | file://0002-remove-unused-execinfo.h.patch \ |
| 17 | file://0003-python-Compilation-warnings-update.patch \ |
| 18 | " |
| 19 | |
| 20 | SRC_URI[sha256sum] = "8dc377255452a68e82c4837ba22c3ee4ae3658971bf0f2ef67ed0b77fc497f91" |
| 21 | |
| 22 | DEPENDS = "bison-native popt libpam glib-2.0 python3" |
| 23 | |
| 24 | inherit autotools features_check gettext python3native python3-dir pkgconfig gtk-doc |
| 25 | |
| 26 | REQUIRED_DISTRO_FEATURES = "pam" |
| 27 | |
| 28 | EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}" |
| 29 | |
| 30 | GTKDOC_DOCDIR = "${S}/docs/reference" |
| 31 | |
| 32 | # run autopoint since it needs ABOUT-NLS and admin/config.rpath from gettext |
| 33 | #EXTRA_AUTORECONF:remove = "--exclude=autopoint" |
| 34 | |
| 35 | do_configure:prepend() { |
| 36 | install -d ${S}/admin -d ${S}/m4 |
| 37 | touch ${S}/ABOUT-NLS ${S}/admin/config.rpath |
| 38 | cd ${S} |
| 39 | bison lib/getdate.y -o lib/getdate.c |
| 40 | cd - |
| 41 | } |
| 42 | |
| 43 | PACKAGES += "${PN}-python " |
| 44 | |
| 45 | FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |
| 46 | |