Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "A fast and lightweight IDE" |
| 2 | HOMEPAGE = "http://plugins.geany.org/" |
| 3 | |
| 4 | LICENSE_DEFAULT = "GPLv2" |
| 5 | LICENSE = "${LICENSE_DEFAULT} & BSD-2-Clause & GPLv3" |
| 6 | |
| 7 | python () { |
| 8 | for plugin in d.getVar('PLUGINS').split(): |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 9 | if 'LICENSE:%s' % plugin not in d: |
| 10 | d.setVar('LICENSE:' + plugin, '${LICENSE_DEFAULT}') |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | } |
| 12 | |
| 13 | DEPENDS = " \ |
| 14 | vala-native \ |
| 15 | fribidi \ |
| 16 | geany \ |
| 17 | libxml2 \ |
| 18 | libsoup-2.4 \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 19 | enchant2 \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | intltool-native \ |
| 21 | libassuan \ |
| 22 | gpgme \ |
| 23 | vte \ |
| 24 | libgit2 \ |
| 25 | " |
| 26 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 27 | inherit features_check autotools pkgconfig gtk-icon-cache |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | |
| 29 | REQUIRED_DISTRO_FEATURES = "x11" |
| 30 | |
| 31 | SRC_URI = " \ |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 32 | https://plugins.geany.org/${BPN}/${BP}.tar.bz2 \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 33 | file://0001-Use-pkg-config-to-find-gpgme.patch \ |
| 34 | " |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 35 | SRC_URI[sha256sum] = "c98f9b1303f4ab9bed7587e749cd0b5594d9136a1bf8ba110900d46a17fa9cd8" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | do_configure:prepend() { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 38 | rm -f ${S}/build/cache/glib-gettext.m4 |
| 39 | } |
| 40 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | FILES:${PN} += "${datadir}/icons" |
| 42 | FILES:${PN}-dev += "${libdir}/geany/*.la ${libdir}/${BPN}/*/*.la" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 43 | |
| 44 | PLUGINS += "${PN}-addons" |
| 45 | LIC_FILES_CHKSUM += "file://addons/COPYING;md5=4325afd396febcb659c36b49533135d4" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 46 | FILES:${PN}-addons = "${libdir}/geany/addons.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 47 | |
| 48 | PLUGINS += "${PN}-autoclose" |
| 49 | LIC_FILES_CHKSUM += "file://autoclose/COPYING;md5=751419260aa954499f7abaabaa882bbe" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 50 | FILES:${PN}-autoclose = "${libdir}/geany/autoclose.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 51 | |
| 52 | PLUGINS += "${PN}-automark" |
| 53 | LIC_FILES_CHKSUM += "file://automark/COPYING;md5=751419260aa954499f7abaabaa882bbe" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 54 | FILES:${PN}-automark = "${libdir}/geany/automark.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 55 | |
| 56 | PLUGINS += "${PN}-codenav" |
| 57 | LIC_FILES_CHKSUM += "file://codenav/COPYING;md5=751419260aa954499f7abaabaa882bbe" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 58 | FILES:${PN}-codenav = "${libdir}/geany/codenav.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 59 | |
| 60 | PLUGINS += "${PN}-commander" |
| 61 | LIC_FILES_CHKSUM += "file://commander/COPYING;md5=d32239bcb673463ab874e80d47fae504" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 62 | LICENSE:${PN}-commander = "GPLv3" |
| 63 | FILES:${PN}-commander = "${libdir}/geany/commander.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 64 | |
| 65 | # | checking whether the GTK version in use is compatible with plugin Debugger... no |
| 66 | EXTRA_OECONF += "--disable-debugger" |
| 67 | #PLUGINS += "${PN}-debugger" |
| 68 | #LIC_FILES_CHKSUM += "file://debugger/COPYING;md5=4325afd396febcb659c36b49533135d4" |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 69 | #FILES:${PN}-debugger = "${libdir}/geany/debugger.so ${datadir}/${PN}/debugger" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 70 | |
| 71 | PLUGINS += "${PN}-defineformat" |
| 72 | LIC_FILES_CHKSUM += "file://defineformat/COPYING;md5=751419260aa954499f7abaabaa882bbe" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 73 | FILES:${PN}-defineformat = "${libdir}/geany/defineformat.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 74 | |
| 75 | # no gnome devhelp in some common layer |
| 76 | EXTRA_OECONF += "--disable-devhelp" |
| 77 | #PLUGINS += "${PN}-devhelp" |
| 78 | #LIC_FILES_CHKSUM += "file://devhelp/COPYING;md5=d32239bcb673463ab874e80d47fae504" |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 79 | #LICENSE:${PN}-devhelp = "GPLv3" |
| 80 | #FILES:${PN}-devhelp = "${libdir}/geany/devhelp.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 81 | |
| 82 | PLUGINS += "${PN}-geanyctags" |
| 83 | LIC_FILES_CHKSUM += "file://geanyctags/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 84 | FILES:${PN}-geanyctags = "${libdir}/geany/geanyctags.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 85 | |
| 86 | PLUGINS += "${PN}-geanydoc" |
| 87 | LIC_FILES_CHKSUM += "file://geanydoc/COPYING;md5=d32239bcb673463ab874e80d47fae504" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 88 | LICENSE:${PN}-geanydoc = "GPLv3" |
| 89 | FILES:${PN}-geanydoc = "${libdir}/geany/geanydoc.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 90 | |
| 91 | PLUGINS += "${PN}-geanyextrasel" |
| 92 | LIC_FILES_CHKSUM += "file://geanyextrasel/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 93 | FILES:${PN}-geanyextrasel = "${libdir}/geany/geanyextrasel.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 94 | |
| 95 | PLUGINS += "${PN}-geanyinsertnum" |
| 96 | LIC_FILES_CHKSUM += "file://geanyinsertnum/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 97 | FILES:${PN}-geanyinsertnum = "${libdir}/geany/geanyinsertnum.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 98 | |
| 99 | # no lua: max supported version is 5.2 |
| 100 | EXTRA_OECONF += "--disable-geanylua" |
| 101 | #PLUGINS += "${PN}-geanylua" |
| 102 | #LIC_FILES_CHKSUM += "file://geanylua/COPYING;md5=4325afd396febcb659c36b49533135d4" |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 103 | #FILES:${PN}-geanylua = "${libdir}/geany/geanylua.so ${libdir}/${PN}/geanylua/*.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 104 | |
| 105 | PLUGINS += "${PN}-geanymacro" |
| 106 | LIC_FILES_CHKSUM += "file://geanymacro/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 107 | FILES:${PN}-geanymacro = "${libdir}/geany/geanymacro.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 108 | |
| 109 | PLUGINS += "${PN}-geanyminiscript" |
| 110 | LIC_FILES_CHKSUM += "file://geanyminiscript/COPYING;md5=4325afd396febcb659c36b49533135d4" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 111 | FILES:${PN}-geanyminiscript = "${libdir}/geany/geanyminiscript.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 112 | |
| 113 | PLUGINS += "${PN}-geanynumberedbookmarks" |
| 114 | LIC_FILES_CHKSUM += "file://geanynumberedbookmarks/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 115 | FILES:${PN}-geanynumberedbookmarks = "${libdir}/geany/geanynumberedbookmarks.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 116 | |
| 117 | PLUGINS += "${PN}-geanypg" |
| 118 | LIC_FILES_CHKSUM += "file://geanypg/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 119 | FILES:${PN}-geanypg = "${libdir}/geany/geanypg.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 120 | |
| 121 | PLUGINS += "${PN}-geanyprj" |
| 122 | LIC_FILES_CHKSUM += "file://geanyprj/COPYING;md5=d32239bcb673463ab874e80d47fae504" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 123 | LICENSE:${PN}-geanyprj = "GPLv3" |
| 124 | FILES:${PN}-geanyprj = "${libdir}/geany/geanyprj.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 125 | |
| 126 | #PLUGINS += "${PN}-geanypy" |
| 127 | #LIC_FILES_CHKSUM += "file://geanypy/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 128 | #FILES:${PN}-geanypy = "${libdir}/geany/geanypy.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 129 | |
| 130 | PLUGINS += "${PN}-geanyvc" |
| 131 | LIC_FILES_CHKSUM += "file://geanyvc/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 132 | FILES:${PN}-geanyvc = "${libdir}/geany/geanyvc.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 133 | |
| 134 | PLUGINS += "${PN}-geniuspaste" |
| 135 | LIC_FILES_CHKSUM += "file://geniuspaste/COPYING;md5=bfc203269f8862ebfc1198cdc809a95a" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 136 | FILES:${PN}-geniuspaste = "${libdir}/geany/geniuspaste.so ${datadir}/${PN}/geniuspaste" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 137 | |
| 138 | PLUGINS += "${PN}-git-changebar" |
| 139 | LIC_FILES_CHKSUM += "file://git-changebar/COPYING;md5=d32239bcb673463ab874e80d47fae504" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 140 | LICENSE:${PN}-git-changebar = "GPLv3" |
| 141 | FILES:${PN}-git-changebar = "${datadir}/${BPN}/git-changebar ${libdir}/geany/git-changebar.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 142 | |
| 143 | PLUGINS += "${PN}-keyrecord" |
| 144 | LIC_FILES_CHKSUM += "file://keyrecord/COPYING;md5=751419260aa954499f7abaabaa882bbe" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 145 | FILES:${PN}-keyrecord = "${libdir}/geany/keyrecord.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 146 | |
| 147 | PLUGINS += "${PN}-latex" |
| 148 | LIC_FILES_CHKSUM += "file://latex/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 149 | FILES:${PN}-latex = "${libdir}/geany/latex.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 150 | |
| 151 | PLUGINS += "${PN}-lineoperations" |
| 152 | LIC_FILES_CHKSUM += "file://lineoperations/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 153 | FILES:${PN}-lineoperations = "${libdir}/geany/lineoperations.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 154 | |
| 155 | PLUGINS += "${PN}-lipsum" |
| 156 | LIC_FILES_CHKSUM += "file://lipsum/COPYING;md5=4325afd396febcb659c36b49533135d4" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 157 | FILES:${PN}-lipsum = "${libdir}/geany/lipsum.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 158 | |
| 159 | # no markdown - avoid floating dependencies |
| 160 | EXTRA_OECONF += "--disable-peg-markdown" |
| 161 | #PLUGINS += "${PN}-markdown" |
| 162 | #LIC_FILES_CHKSUM += "file://markdown/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 163 | #FILES:${PN}-markdown = "${libdir}/geany/markdown.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 164 | |
| 165 | # | checking whether the GTK version in use is compatible with plugin multiterm... no |
| 166 | EXTRA_OECONF += "--disable-multiterm" |
| 167 | #PLUGINS += "${PN}-multiterm" |
| 168 | #LIC_FILES_CHKSUM += "file://multiterm/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 169 | #FILES:${PN}-multiterm = "${libdir}/geany/multiterm.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 170 | |
| 171 | PLUGINS += "${PN}-overview" |
| 172 | LIC_FILES_CHKSUM += "file://overview/overview/overviewplugin.c;beginline=4;endline=20;md5=1aa33522916cdeb46cccac0c629da0d0" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 173 | FILES:${PN}-overview = "${libdir}/geany/overview.so ${datadir}/${PN}/overview" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 174 | |
| 175 | PLUGINS += "${PN}-pairtaghighlighter" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 176 | LICENSE:${PN}-pairtaghighlighter = "BSD-2-Clause" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 177 | LIC_FILES_CHKSUM += "file://pairtaghighlighter/COPYING;md5=d6d927525a612b3a8dbebc4b2e9b47c1" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 178 | FILES:${PN}-pairtaghighlighter = "${libdir}/geany/pairtaghighlighter.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 179 | |
| 180 | PLUGINS += "${PN}-pohelper" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 181 | LICENSE:${PN}-pohelper = "GPLv3" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 182 | LIC_FILES_CHKSUM += "file://pohelper/COPYING;md5=d32239bcb673463ab874e80d47fae504" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 183 | FILES:${PN}-pohelper = "${datadir}/${BPN}/pohelper ${libdir}/geany/pohelper.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 184 | |
| 185 | PLUGINS += "${PN}-pretty-printer" |
| 186 | LIC_FILES_CHKSUM += "file://pretty-printer/src/PrettyPrinter.c;beginline=1;endline=17;md5=1665115c2fadb17c1b53cdb4e43b2440" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 187 | FILES:${PN}-pretty-printer = "${libdir}/geany/pretty-printer.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 188 | |
| 189 | PLUGINS += "${PN}-projectorganizer" |
| 190 | LIC_FILES_CHKSUM += "file://projectorganizer/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 191 | FILES:${PN}-projectorganizer = "${libdir}/geany/projectorganizer.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 192 | |
| 193 | PLUGINS += "${PN}-scope" |
| 194 | LIC_FILES_CHKSUM += "file://scope/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 195 | FILES:${PN}-scope = "${datadir}/${BPN}/scope ${libdir}/geany/scope.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 196 | |
| 197 | PLUGINS += "${PN}-sendmail" |
| 198 | LIC_FILES_CHKSUM += "file://sendmail/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 199 | FILES:${PN}-sendmail = "${libdir}/geany/sendmail.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 200 | |
| 201 | PLUGINS += "${PN}-shiftcolumn" |
| 202 | LIC_FILES_CHKSUM += "file://shiftcolumn/COPYING;md5=751419260aa954499f7abaabaa882bbe" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 203 | FILES:${PN}-shiftcolumn = "${libdir}/geany/shiftcolumn.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 204 | |
| 205 | PLUGINS += "${PN}-spellcheck" |
| 206 | LIC_FILES_CHKSUM += "file://spellcheck/COPYING;md5=4325afd396febcb659c36b49533135d4" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 207 | FILES:${PN}-spellcheck = "${libdir}/geany/spellcheck.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 208 | |
| 209 | PLUGINS += "${PN}-tableconvert" |
| 210 | LIC_FILES_CHKSUM += "file://tableconvert/COPYING;md5=6753686878d090a1f3f9445661d3dfbc" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 211 | FILES:${PN}-tableconvert = "${libdir}/geany/tableconvert.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 212 | |
| 213 | PLUGINS += "${PN}-treebrowser" |
| 214 | LIC_FILES_CHKSUM += "file://treebrowser/README;beginline=67;endline=67;md5=1f17f0f2abb88e0fa0f1b342112d871c" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 215 | FILES:${PN}-treebrowser = "${libdir}/geany/treebrowser.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 216 | |
| 217 | PLUGINS += "${PN}-updatechecker" |
| 218 | LIC_FILES_CHKSUM += "file://updatechecker/COPYING;md5=4325afd396febcb659c36b49533135d4" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 219 | FILES:${PN}-updatechecker = "${libdir}/geany/updatechecker.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 220 | |
| 221 | PLUGINS += "${PN}-vimode" |
| 222 | LIC_FILES_CHKSUM += "file://vimode/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 223 | FILES:${PN}-vimode = "${libdir}/geany/vimode.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 224 | |
| 225 | # no webkit - lasts ages and is not properly detected |
| 226 | EXTRA_OECONF += " --disable-webhelper" |
| 227 | #PLUGINS += "${PN}-webhelper" |
| 228 | #LIC_FILES_CHKSUM += "file://webhelper/COPYING;md5=d32239bcb673463ab874e80d47fae504" |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 229 | #LICENSE:${PN}-webhelper = "GPLv3" |
| 230 | #FILES:${PN}-webhelper = "${libdir}/geany/webhelper.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 231 | |
| 232 | PLUGINS += "${PN}-workbench" |
| 233 | LIC_FILES_CHKSUM += "file://workbench/COPYING;md5=c107cf754550e65755c42985a5d4e9c9" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 234 | FILES:${PN}-workbench = "${libdir}/geany/workbench.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 235 | |
| 236 | PLUGINS += "${PN}-xmlsnippets" |
| 237 | LIC_FILES_CHKSUM += "file://xmlsnippets/COPYING;md5=4325afd396febcb659c36b49533135d4" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 238 | FILES:${PN}-xmlsnippets = "${libdir}/geany/xmlsnippets.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 239 | |
| 240 | PACKAGES =+ "${PN}-common ${PLUGINS}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 241 | FILES:${PN}-common = "${libdir}/libgeanypluginutils${SOLIBS}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 242 | |
| 243 | # geany-plugins is meta package for all plugins |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 244 | RDEPENDS:${PN} = "${PLUGINS}" |
| 245 | ALLOW_EMPTY:${PN} = "1" |