Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Maintenance tools for OverlayFS" |
| 2 | HOMEPAGE = "https://github.com/kmxz/overlayfs-tools" |
| 3 | LICENSE = "WTFPL" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f312a7c4d02230e8f2b537295d375c69" |
| 5 | |
| 6 | SRC_URI = "\ |
| 7 | git://github.com/kmxz/overlayfs-tools.git;protocol=https;branch=master \ |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 8 | " |
| 9 | |
| 10 | PV = "1.0+git${SRCPV}" |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 11 | SRCREV = "b5e5a829895ac98ccfe4629fbfbd8b819262bd00" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | B = "${S}" |
| 15 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 16 | # Required to have the fts.h header for musl |
| 17 | DEPENDS:append:libc-musl = " fts" |
| 18 | |
| 19 | EXTRA_OEMAKE += "'CC=${CC} -O2'" |
| 20 | # Fix the missing fts libs when using musl |
| 21 | EXTRA_OEMAKE:append:libc-musl = " LDLIBS=-lfts" |
| 22 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 23 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 24 | do_install () { |
| 25 | install -d ${D}${bindir} |
| 26 | install -m 0755 ${B}/overlay ${D}${bindir} |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 27 | install -m 0755 ${B}/fsck.overlay ${D}${bindir} |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 28 | } |