blob: ca2ec9cc4f1aae2e32c1228ae2ff896bc27281af [file] [log] [blame]
Andrew Geissler78b72792022-06-14 06:47:25 -05001DESCRIPTION = "Maintenance tools for OverlayFS"
2HOMEPAGE = "https://github.com/kmxz/overlayfs-tools"
3LICENSE = "WTFPL"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f312a7c4d02230e8f2b537295d375c69"
5
6SRC_URI = "\
7 git://github.com/kmxz/overlayfs-tools.git;protocol=https;branch=master \
Andrew Geissler78b72792022-06-14 06:47:25 -05008"
9
10PV = "1.0+git${SRCPV}"
Andrew Geissler220dafd2023-10-04 10:18:08 -050011SRCREV = "b5e5a829895ac98ccfe4629fbfbd8b819262bd00"
Andrew Geissler78b72792022-06-14 06:47:25 -050012
13S = "${WORKDIR}/git"
14B = "${S}"
15
Andrew Geissler78b72792022-06-14 06:47:25 -050016# Required to have the fts.h header for musl
17DEPENDS:append:libc-musl = " fts"
18
19EXTRA_OEMAKE += "'CC=${CC} -O2'"
20# Fix the missing fts libs when using musl
21EXTRA_OEMAKE:append:libc-musl = " LDLIBS=-lfts"
22TARGET_CC_ARCH += "${LDFLAGS}"
23
Andrew Geissler78b72792022-06-14 06:47:25 -050024do_install () {
25 install -d ${D}${bindir}
26 install -m 0755 ${B}/overlay ${D}${bindir}
Andrew Geissler220dafd2023-10-04 10:18:08 -050027 install -m 0755 ${B}/fsck.overlay ${D}${bindir}
Andrew Geissler78b72792022-06-14 06:47:25 -050028}