blob: ae251b5a088e400d5b9732e7922a3a351775d77b [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "multi-protocol instant messaging client"
Andrew Geisslerac970dd2021-02-12 15:32:45 -06002
Brad Bishopd7bf8c12018-02-25 22:55:05 -05003SECTION = "x11/network"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
Brad Bishop996bc452019-12-02 13:05:15 -05006DEPENDS = "python3 virtual/libintl intltool-native libxml2 gconf glib-2.0-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007
Brad Bishop996bc452019-12-02 13:05:15 -05008inherit autotools gettext pkgconfig gconf perlnative python3native
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
10SRC_URI = "\
11 ${SOURCEFORGE_MIRROR}/pidgin/pidgin-${PV}.tar.bz2 \
12 file://sanitize-configure.ac.patch \
13 file://purple-OE-branding-25.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014"
15
Andrew Geisslere34f8962021-04-15 15:53:51 -050016SRC_URI[sha256sum] = "19654ad276b149646371fbdac21bc7620742f2975f7399fed0ffc1a18fbaf603"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017
Patrick Williams2a254922023-08-11 09:48:11 -050018CVE_STATUS[CVE-2010-1624] = "fixed-version: The CPE in the NVD database doesn't reflect correctly the vulnerable versions."
19CVE_STATUS[CVE-2011-3594] = "fixed-version: The CPE in the NVD database doesn't reflect correctly the vulnerable versions."
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050020
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021PACKAGECONFIG ??= "gnutls consoleui avahi dbus idn nss \
22 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtk startup-notification', '', d)} \
23"
24PACKAGECONFIG[farsight2] = "--enable-farstream,--disable-farstream,farsight2"
25# --disable-gstreamer compile without GStreamer audio support
26# --disable-gstreamer-video
27# compile without GStreamer 1.0 Video Overlay support
28# --disable-gstreamer-interfaces
29# compile without GStreamer 0.10 interface support
30# --with-gstreamer=<version>
31# compile with GStreamer 0.10 or 1.0 interface
32PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
33PACKAGECONFIG[vv] = "--enable-vv,--disable-vv,gstreamer"
34PACKAGECONFIG[idn] = "--enable-idn,--disable-idn,libidn"
35PACKAGECONFIG[gtk] = "--enable-gtkui,--disable-gtkui,gtk+"
36PACKAGECONFIG[x11] = "--with-x=yes --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--with-x=no,virtual/libx11"
37PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060038PACKAGECONFIG[consoleui] = "--enable-consoleui --with-ncurses-headers=${STAGING_INCDIR},--disable-consoleui,libgnt"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039PACKAGECONFIG[gnutls] = "--enable-gnutls --with-gnutls-includes=${STAGING_INCDIR} --with-gnutls-libs=${STAGING_LIBDIR},--disable-gnutls,gnutls,libpurple-plugin-ssl-gnutls"
40PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
41PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
42PACKAGECONFIG[nss] = "--enable-nss,--disable-nss,nss nspr,libpurple-plugin-ssl-nss"
Andrew Geisslere34f8962021-04-15 15:53:51 -050043PACKAGECONFIG[cyrus-sasl] = "--enable-cyrus-sasl,--disable-cyrus-sasl,cyrus-sasl"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050044
45EXTRA_OECONF = " \
46 --disable-perl \
47 --disable-tcl \
48 --disable-gevolution \
49 --disable-schemas-install \
50 --disable-gtkspell \
51 --disable-meanwhile \
52 --disable-nm \
53 --disable-screensaver \
54"
55
Brad Bishopd7bf8c12018-02-25 22:55:05 -050056OE_LT_RPATH_ALLOW=":${libdir}/purple-2:"
57OE_LT_RPATH_ALLOW[export]="1"
58
Andrew Geisslerac970dd2021-02-12 15:32:45 -060059PACKAGES =+ "libpurple-dev libpurple finch finch-dev ${PN}-data"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080060
Patrick Williams213cb262021-08-07 19:21:33 -050061RPROVIDES:${PN}-dbg += "libpurple-dbg finch-dbg"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050062
63LEAD_SONAME = "libpurple.so.0"
Patrick Williams213cb262021-08-07 19:21:33 -050064FILES:libpurple = "${libdir}/libpurple*.so.* ${libdir}/purple-2 ${bindir}/purple-* ${sysconfdir}/gconf/schemas/purple* ${datadir}/purple/ca-certs"
65FILES:libpurple-dev = "${libdir}/libpurple*.la \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050066 ${libdir}/libpurple*.so \
67 ${libdir}/purple-2/*.la \
68 ${libdir}/purple-2/libjabber.so \
69 ${libdir}/purple-2/liboscar.so \
70 ${libdir}/purple-2/libymsg.so \
71 ${datadir}/aclocal"
Patrick Williams213cb262021-08-07 19:21:33 -050072FILES:finch = "${bindir}/finch"
73FILES:finch-dev = "${libdir}/finch/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050074
Patrick Williams213cb262021-08-07 19:21:33 -050075FILES:${PN} = "${bindir} ${datadir}/${PN} ${libdir}/${PN}/*.so \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050076 ${datadir}/applications"
Patrick Williams213cb262021-08-07 19:21:33 -050077RRECOMMENDS:${PN} = "${PN}-data libpurple-protocol-irc libpurple-protocol-xmpp"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050078
Patrick Williams213cb262021-08-07 19:21:33 -050079FILES:${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons ${datadir}/appdata"
80FILES:${PN}-dev += "${libdir}/${PN}/*.la"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050081
82PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*"
83
Patrick Williams213cb262021-08-07 19:21:33 -050084python populate_packages:prepend () {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050085 pidgroot = d.expand('${libdir}/pidgin')
86 purple = d.expand('${libdir}/purple-2')
87 finch = d.expand('${libdir}/finch')
88
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000089 do_split_packages(d, pidgroot, r'^([^l][^i][^b].*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -050090 output_pattern='pidgin-plugin-%s',
91 description='Pidgin plugin %s',
92 prepend=True, extra_depends='')
93
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000094 do_split_packages(d, purple, r'^lib(.*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -050095 output_pattern='libpurple-protocol-%s',
96 description='Libpurple protocol plugin for %s',
97 prepend=True, extra_depends='')
98
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000099 do_split_packages(d, purple, r'^(ssl-.*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500100 output_pattern='libpurple-plugin-%s',
101 description='libpurple plugin %s',
102 prepend=True, extra_depends='libpurple-plugin-ssl')
103
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000104 do_split_packages(d, purple, r'^([^l][^i][^b].*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500105 output_pattern='libpurple-plugin-%s',
106 description='libpurple plugin %s',
107 prepend=True, extra_depends='')
108
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000109 do_split_packages(d, finch, r'^([^l][^i][^b].*)\.so$',
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500110 output_pattern='finch-plugin-%s',
111 description='Finch plugin %s',
112 prepend=True, extra_depends='')
113}