Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \ |
| 2 | for the development of SOAP Web Services and clients." |
| 3 | SECTION = "devel" |
| 4 | LICENSE = "GPL-2.0-with-OpenSSL-exception" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4f40a941379143186f9602242c3fb729 \ |
| 6 | file://GPLv2_license.txt;md5=a33672dbe491b6517750a0389063508b" |
| 7 | |
| 8 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}2/${BPN}_${PV}.zip \ |
| 9 | file://0001-Fix-out-of-tree-builds.patch \ |
| 10 | file://0001-stdgsoap2-Fix-build-with-musl.patch \ |
| 11 | " |
| 12 | SRC_URI[md5sum] = "212951d6e1435bb51fa4320f458809ea" |
| 13 | SRC_URI[sha256sum] = "3e7bb24a9e492f5cb86daca34054c9787152f1d7b70add36b789d03816d5ffa1" |
| 14 | |
| 15 | inherit autotools |
| 16 | |
| 17 | BBCLASSEXTEND = "native" |
| 18 | |
| 19 | S = "${WORKDIR}/${BPN}-2.8" |
| 20 | |
| 21 | PARALLEL_MAKE = "" |
| 22 | |
| 23 | EXTRA_OEMAKE_class-target = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2" |
| 24 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | DEPENDS = "openssl zlib flex bison bison-native" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 26 | DEPENDS_append_class-target = " gsoap-native" |
| 27 | |
| 28 | do_install_append() { |
| 29 | install -d ${D}${libdir} |
| 30 | for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck |
| 31 | do |
| 32 | oe_libinstall -C gsoap $lib ${D}${libdir} |
| 33 | done |
| 34 | } |
| 35 | |
| 36 | do_install_class-native() { |
| 37 | oe_runmake DESTDIR=${D} BINDIR=${D}${bindir} install |
| 38 | } |
| 39 | |
| 40 | FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2" |
| 41 | FILES_${PN} += "${datadir}" |
| 42 | FILES_${PN}-staticdev = "${libdir}" |
| 43 | FILES_${PN}-dev = "${includedir}" |
| 44 | RRECOMMENDS_${PN}-dev = "${PN}-staticdev" |