blob: 163d732a86579f875be1c8043b10f36b7d31d97e [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Desktop containment framework."
2HOMEPAGE = "http://flatpak.org"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6SRC_URI = " \
7 gitsm://github.com/flatpak/flatpak;protocol=https;nobranch=1 \
8 file://0001-flatpak-pc-add-pc_sysrootdir.patch \
9"
10
Patrick Williams8e7b46e2023-05-01 14:19:06 -050011SRCREV = "e936e3100d406c50ba49f3ad6a0ecae455345ec0"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13S = "${WORKDIR}/git"
14
15inherit meson pkgconfig gettext systemd gobject-introspection python3native useradd mime features_check
16
17REQUIRED_DISTRO_FEATURES = "polkit"
18
19DEPENDS = " \
20 appstream \
21 bison-native \
22 curl \
23 dconf \
24 fuse3 \
25 gdk-pixbuf \
26 glib-2.0 \
27 gpgme \
28 json-glib \
29 libarchive \
30 libcap \
Andrew Geissler8f840682023-07-21 09:09:43 -050031 libxml2 \
Andrew Geissler517393d2023-01-13 08:55:19 -060032 libxslt-native \
33 ostree \
34 polkit \
35 python3-pyparsing-native \
36 xmlto-native \
Andrew Geissler8f840682023-07-21 09:09:43 -050037 zstd \
Andrew Geissler517393d2023-01-13 08:55:19 -060038"
39
40RDEPENDS:${PN} = " \
41 bubblewrap \
42 ca-certificates \
43 dconf \
44 flatpak-xdg-utils \
Andrew Geissler8f840682023-07-21 09:09:43 -050045 xdg-dbus-proxy \
Andrew Geissler517393d2023-01-13 08:55:19 -060046"
47
Andrew Geissler8f840682023-07-21 09:09:43 -050048EXTRA_OEMESON += "-Dsystem_dbus_proxy=${bindir}/xdg-dbus-proxy -Dsystem_bubblewrap=${bindir}/bwrap"
49
Andrew Geissler517393d2023-01-13 08:55:19 -060050GIR_MESON_OPTION = ""
51
Andrew Geissler8f840682023-07-21 09:09:43 -050052PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,xauth socat-native"
Andrew Geissler517393d2023-01-13 08:55:19 -060053PACKAGECONFIG[xauth] = "-Dxauth=enabled,-Dxauth=disabled,xauth"
54PACKAGECONFIG[seccomp] = "-Dseccomp=enabled,-Dseccomp=disabled,libseccomp"
55
56PACKAGECONFIG ?= " \
57 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xauth', '', d)} \
Andrew Geissler8f840682023-07-21 09:09:43 -050058 ${@bb.utils.contains('DISTRO_FEATURES', 'seccomp', 'seccomp', '', d)} \
Andrew Geissler517393d2023-01-13 08:55:19 -060059"
60
61FILES:${PN} += "${libdir} ${datadir}"
62
63USERADD_PACKAGES = "${PN}"
64USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd"
65
66do_install:append() {
67 chmod 0700 ${D}/${datadir}/polkit-1/rules.d
68 chown polkitd ${D}/${datadir}/polkit-1/rules.d
69 chgrp root ${D}/${datadir}/polkit-1/rules.d
70}