Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Boot strap code that the GPU puts on memory to start running the boot loader" |
Brad Bishop | cae294d | 2019-10-28 08:43:55 -0400 | [diff] [blame] | 2 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 3 | |
| 4 | LIC_FILES_CHKSUM = "file://armstub.S;beginline=1;endline=26;md5=9888f34ac06a676129416c952a6a521e" |
| 5 | |
| 6 | inherit deploy nopackages |
| 7 | |
| 8 | include recipes-bsp/common/raspberrypi-tools.inc |
| 9 | |
| 10 | COMPATIBLE_MACHINE = "^rpi$" |
| 11 | |
| 12 | S = "${RPITOOLS_S}/armstubs" |
| 13 | |
Brad Bishop | 1b9ee29 | 2020-01-16 09:06:00 -0500 | [diff] [blame] | 14 | export CC7="${CC}" |
| 15 | export LD7="${LD}" |
| 16 | export OBJCOPY7="${OBJCOPY}" |
| 17 | export OBJDUMP7="${OBJDUMP}" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 18 | export CC8="${CC}" |
| 19 | export LD8="${LD}" |
| 20 | export OBJCOPY8="${OBJCOPY}" |
| 21 | export OBJDUMP8="${OBJDUMP} -maarch64" |
| 22 | |
| 23 | do_compile() { |
| 24 | [ -z "${ARMSTUB}" ] && bbfatal "No ARMSTUB defined for your machine." |
| 25 | oe_runmake ${ARMSTUB} |
| 26 | } |
| 27 | |
| 28 | do_deploy() { |
| 29 | install -d ${DEPLOYDIR}/${PN} |
| 30 | cp ${S}/armstub*.bin ${DEPLOYDIR}/${PN} |
| 31 | } |
| 32 | |
| 33 | addtask deploy before do_build after do_install |
| 34 | do_deploy[dirs] += "${DEPLOYDIR}/${PN}" |
| 35 | |
| 36 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
Andrew Geissler | 26e4bea | 2020-11-30 19:54:03 -0600 | [diff] [blame] | 37 | |
| 38 | TOOLCHAIN = "gcc" |