Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Linux encrypted filesystem management tool" |
| 2 | HOMEPAGE = "http://cryptmount.sourceforge.net/" |
Andrew Geissler | 2daf84b | 2023-03-31 09:57:23 -0500 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://COPYING;beginline=1;endline=4;md5=6e69c425bf32ecf9b1e11d29d146d03d" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 4 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 2daf84b | 2023-03-31 09:57:23 -0500 | [diff] [blame] | 5 | SRC_URI = "https://sourceforge.net/projects/cryptmount/files/${BPN}/${BPN}-6.2/${BPN}-${PV}.tar.gz" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 6 | |
Andrew Geissler | 2daf84b | 2023-03-31 09:57:23 -0500 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "90cc49fd598d636929c70479b1305f12b011edadf4a54578ace6c0fca8cb5ed2" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 8 | |
| 9 | inherit autotools-brokensep gettext pkgconfig systemd |
| 10 | |
| 11 | EXTRA_OECONF = " --enable-cswap --enable-fsck --enable-argv0switch" |
| 12 | |
| 13 | PACKAGECONFIG ?="intl luks gcrypt nls" |
| 14 | PACKAGECONFIG:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" |
| 15 | |
| 16 | PACKAGECONFIG[systemd] = "--with-systemd, --without-systemd, systemd" |
| 17 | PACKAGECONFIG[intl] = "--with-libintl-prefix, --without-libintl-prefix" |
| 18 | PACKAGECONFIG[gcrypt] = "--with-libgcrypt, --without-libgcrypt, libgcrypt" |
| 19 | PACKAGECONFIG[luks] = "--enable-luks, --disable-luks, cryptsetup" |
| 20 | PACKAGECONFIG[nls] = "--enable-nls, --disable-nls, " |
| 21 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 22 | SYSTEMD_PACKAGES = "${PN}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 23 | SYSTEMD_SERVICE:${PN} = "cryptmount.service" |
| 24 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 25 | do_install:append () { |
| 26 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 27 | install -D -m 0644 ${S}/sysinit/cryptmount.service ${D}${systemd_system_unitdir}/cryptmount.service |
| 28 | rm -fr ${D}/usr/lib |
| 29 | fi |
| 30 | } |
| 31 | |
| 32 | FILES:${PN} += "${systemd_system_unitdir}" |
| 33 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 34 | RDEPENDS:${PN} = "libdevmapper" |