blob: b3534ad678e8f6d113d5910294c0921e7a3a2abc [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3DESCRIPTION = "Python is a programming language that lets you work more quickly and integrate your systems more effectively."
4LICENSE = "PSF-2.0"
5SECTION = "devel/python"
6
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06007LIC_FILES_CHKSUM = "file://LICENSE;md5=fcf6b249c2641540219a727f35d8d2c2"
Andrew Geissler517393d2023-01-13 08:55:19 -06008
9SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
10 file://run-ptest \
11 file://create_manifest3.py \
12 file://get_module_deps3.py \
13 file://python3-manifest.json \
14 file://check_build_completeness.py \
15 file://reformat_sysconfig.py \
16 file://cgi_py.patch \
17 file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \
18 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \
19 file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \
20 file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \
21 file://crosspythonpath.patch \
22 file://0001-test_locale.py-correct-the-test-output-format.patch \
23 file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \
24 file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \
25 file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \
26 file://0001-Skip-failing-tests-due-to-load-variability-on-YP-AB.patch \
27 file://0001-test_ctypes.test_find-skip-without-tools-sdk.patch \
28 file://makerace.patch \
29 file://0001-sysconfig.py-use-platlibdir-also-for-purelib.patch \
30 file://0001-Lib-pty.py-handle-stdin-I-O-errors-same-way-as-maste.patch \
31 file://0001-setup.py-Do-not-detect-multiarch-paths-when-cross-co.patch \
32 file://deterministic_imports.patch \
33 file://0001-Avoid-shebang-overflow-on-python-config.py.patch \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050034 file://0001-Update-test_sysconfig-for-posix_user-purelib.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060035 "
36
37SRC_URI:append:class-native = " \
38 file://0001-Lib-sysconfig.py-use-prefix-value-from-build-configu.patch \
39 file://12-distutils-prefix-is-inside-staging-area.patch \
40 file://0001-Don-t-search-system-for-headers-libraries.patch \
41 "
Andrew Geissler8f840682023-07-21 09:09:43 -050042SRC_URI[sha256sum] = "2f0e409df2ab57aa9fc4cbddfb976af44e4e55bf6f619eee6bc5c2297264a7f6"
Andrew Geissler517393d2023-01-13 08:55:19 -060043
44# exclude pre-releases for both python 2.x and 3.x
45UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
46UPSTREAM_CHECK_URI = "https://www.python.org/downloads/source/"
47
48CVE_PRODUCT = "python"
49
Andrew Geissler8f840682023-07-21 09:09:43 -050050CVE_STATUS[CVE-2007-4559] = "disputed: Upstream consider this expected behaviour"
51CVE_STATUS[CVE-2019-18348] = "not-applicable-config: This is not exploitable when glibc has CVE-2016-10739 fixed"
52CVE_STATUS[CVE-2020-15523] = "not-applicable-platform: Issue only applies on Windows"
53CVE_STATUS[CVE-2022-26488] = "not-applicable-platform: Issue only applies on Windows"
Andrew Geissler517393d2023-01-13 08:55:19 -060054# The module will be removed in the future and flaws documented.
Andrew Geissler8f840682023-07-21 09:09:43 -050055CVE_STATUS[CVE-2015-20107] = "upstream-wontfix: The mailcap module is insecure by design, so this can't be fixed in a meaningful way"
56# CVE_STATUS[CVE-2023-36632] = "disputed: Not an issue, in fact expected behaviour"
Andrew Geissler517393d2023-01-13 08:55:19 -060057
58PYTHON_MAJMIN = "3.11"
59
60S = "${WORKDIR}/Python-${PV}"
61
62BBCLASSEXTEND = "native nativesdk"
63
64inherit autotools pkgconfig qemu ptest multilib_header update-alternatives
65
66MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
67
68ALTERNATIVE:${PN}-dev = "python3-config"
69ALTERNATIVE_LINK_NAME[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config"
70ALTERNATIVE_TARGET[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}"
71
72
Andrew Geissler3eeda902023-05-19 10:14:02 -050073DEPENDS = "bzip2-replacement-native expat libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux-libuuid libtirpc libnsl2 autoconf-archive-native ncurses"
Andrew Geissler517393d2023-01-13 08:55:19 -060074DEPENDS:append:class-target = " python3-native"
75DEPENDS:append:class-nativesdk = " python3-native"
76
Andrew Geissler3eeda902023-05-19 10:14:02 -050077EXTRA_OECONF = " --without-ensurepip --enable-shared --with-platlibdir=${baselib} --with-system-expat"
Andrew Geissler517393d2023-01-13 08:55:19 -060078EXTRA_OECONF:append:class-native = " --bindir=${bindir}/${PN}"
79EXTRA_OECONF:append:class-target = " --with-build-python=nativepython3"
80EXTRA_OECONF:append:class-nativesdk = " --with-build-python=nativepython3"
81
82export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
83
84EXTRANATIVEPATH += "python3-native"
85
86# LTO will be enabled via packageconfig depending upong distro features
87LTO:class-target = ""
88
89CACHED_CONFIGUREVARS = " \
90 ac_cv_file__dev_ptmx=yes \
91 ac_cv_file__dev_ptc=no \
92 ac_cv_working_tzset=yes \
93"
94
95# PGO currently causes builds to not be reproducible so disable by default, see YOCTO #13407
Andrew Geissler3eeda902023-05-19 10:14:02 -050096PACKAGECONFIG ??= "editline gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
97PACKAGECONFIG[readline] = "--with-readline=readline,,readline,,,editline"
Andrew Geissler517393d2023-01-13 08:55:19 -060098PACKAGECONFIG[editline] = "--with-readline=editline,,libedit,,,readline"
99# Use profile guided optimisation by running PyBench inside qemu-user
100PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
101PACKAGECONFIG[tk] = ",,tk"
102PACKAGECONFIG[tcl] = ",,tcl"
103PACKAGECONFIG[gdbm] = ",,gdbm"
Andrew Geissler3eeda902023-05-19 10:14:02 -0500104PACKAGECONFIG[lto] = "--with-lto,--without-lto"
Andrew Geissler517393d2023-01-13 08:55:19 -0600105
106do_configure:prepend () {
107 mkdir -p ${B}/Modules
108 cat > ${B}/Modules/Setup.local << EOF
109*disabled*
110${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)}
111${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)}
112EOF
113}
114
115CPPFLAGS:append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"
116
117EXTRA_OEMAKE = '\
118 STAGING_LIBDIR=${STAGING_LIBDIR} \
119 STAGING_INCDIR=${STAGING_INCDIR} \
120 LIB=${baselib} \
121'
122
123do_compile:prepend:class-target() {
124 if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then
125 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}"
126 cat >pgo-wrapper <<EOF
127#!/bin/sh
128cd ${B}
129$qemu_binary "\$@"
130EOF
131 chmod +x pgo-wrapper
132 fi
133}
134
135do_install:prepend() {
136 ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile
137}
138
139do_install:append:class-target() {
140 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
141}
142
143do_install:append:class-native() {
144 # Make sure we use /usr/bin/env python
145 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
146 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
147 done
148 # Add a symlink to the native Python so that scripts can just invoke
149 # "nativepython" and get the right one without needing absolute paths
150 # (these often end up too long for the #! parser in the kernel as the
151 # buffer is 128 bytes long).
152 ln -s python3-native/python3 ${D}${bindir}/nativepython3
153
154 # Remove the opt-1.pyc and opt-2.pyc files. There are over 3,000 of them
155 # and the overhead in each recipe-sysroot-native isn't worth it, particularly
156 # when they're only used for python called with -O or -OO.
157 #find ${D} -name *opt-*.pyc -delete
158 # Remove all pyc files. There are a ton of them and it is probably faster to let
159 # python create the ones it wants at runtime rather than manage in the sstate
160 # tarballs and sysroot creation.
161 find ${D} -name *.pyc -delete
162
163 # Nothing should be looking into ${B} for python3-native
164 sed -i -e 's:${B}:/build/path/unavailable/:g' \
165 ${D}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile
166
167 # disable the lookup in user's site-packages globally
168 sed -i 's#ENABLE_USER_SITE = None#ENABLE_USER_SITE = False#' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py
169
170 # python3-config needs to be in /usr/bin and not in a subdir of it to work properly
171 mv ${D}/${bindir}/${PN}/python*config ${D}/${bindir}/
172}
173
174do_install:append() {
175 for c in ${D}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
176 python3 ${WORKDIR}/reformat_sysconfig.py $c
177 done
178 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/_sysconfigdata*.cpython*
179
180 mkdir -p ${D}${libdir}/python-sysconfigdata
181 sysconfigfile=`find ${D} -name _sysconfig*.py`
182 sed -i \
183 -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
184 -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
185 -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
186 -e "s,^ 'INCLUDEPY'.*, 'INCLUDEPY': '${STAGING_INCDIR}/python${PYTHON_MAJMIN}'\,,g" \
187 -e "s,^ 'CONFINCLUDEPY'.*, 'CONFINCLUDEPY': '${STAGING_INCDIR}/python${PYTHON_MAJMIN}'\,,g" \
188 -e "s,${B},/build/path/unavailable/,g" \
189 $sysconfigfile
190 cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
191
192
193 # Unfortunately the following pyc files are non-deterministc due to 'frozenset'
194 # being written without strict ordering, even with PYTHONHASHSEED = 0
195 # Upstream is discussing ways to solve the issue properly, until then let's
196 # just not install the problematic files.
197 # More info: http://benno.id.au/blog/2013/01/15/python-determinism
198 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_range.cpython*
199 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_xml_etree.cpython*
200
201 # Similar to the above, we're getting reproducibility issues with
202 # /usr/lib/python3.10/__pycache__/traceback.cpython-310.pyc
203 # so remove it too
204 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/traceback.cpython*
205
206 # Remove the opt-1.pyc and opt-2.pyc files. They effectively waste space on embedded
207 # style targets as they're only used when python is called with the -O or -OO options
208 # which is rare.
209 find ${D} -name *opt-*.pyc -delete
210}
211
212do_install:append:class-nativesdk () {
213 # Make sure we use /usr/bin/env python
214 for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
215 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
216 done
217 create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
218}
219
220SYSROOT_PREPROCESS_FUNCS:append:class-target = " provide_target_config_script"
221SYSROOT_PREPROCESS_FUNCS:append:class-nativesdk = " provide_target_config_script"
222
223# This is installed into /usr/python-target-config/ and not /usr/bin
224# because adding target sysroot's /usr/bin/ to PATH has unwanted side effects
225# in components erroneously picking up other target executables from it
226provide_target_config_script() {
227 install -d ${SYSROOT_DESTDIR}${prefix}/python-target-config/
228 install ${D}/${bindir}/python3-config ${SYSROOT_DESTDIR}/${prefix}/python-target-config/
229 install ${D}/${bindir}/python${PYTHON_MAJMIN}-config ${SYSROOT_DESTDIR}/${prefix}/python-target-config/
230}
231SYSROOT_DIRS += "${prefix}/python-target-config/"
232
233SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py"
234SSTATE_HASHEQUIV_FILEMAP = " \
235 populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${TMPDIR} \
236 populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${COREBASE} \
237 populate_sysroot:*/lib*/python3*/config-*/Makefile:${TMPDIR} \
238 populate_sysroot:*/lib*/python3*/config-*/Makefile:${COREBASE} \
239 populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${TMPDIR} \
240 populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${COREBASE} \
241 "
242PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
243
244py_package_preprocess () {
245 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
246 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
247 -e 's|${DEBUG_PREFIX_MAP}||g' \
248 -e 's:${HOSTTOOLS_DIR}/::g' \
249 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
250 -e 's:${RECIPE_SYSROOT}::g' \
251 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
252 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \
253 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
254 ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config
255
256 # Reformat _sysconfigdata after modifying it so that it remains
257 # reproducible
258 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
259 python3 ${WORKDIR}/reformat_sysconfig.py $c
260 done
261
262 # Recompile _sysconfigdata after modifying it
263 cd ${PKGD}
264 sysconfigfile=`find . -name _sysconfigdata_*.py`
265 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
266 -c "from py_compile import compile; compile('$sysconfigfile')"
267 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
268 -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)"
269 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
270 -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)"
271 cd -
272
273 mv ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}
274
275 #Remove the unneeded copy of target sysconfig data
276 rm -rf ${PKGD}/${libdir}/python-sysconfigdata
277}
278
279# We want bytecode precompiled .py files (.pyc's) by default
280# but the user may set it on their own conf
281INCLUDE_PYCS ?= "1"
282
283python(){
284 import collections, json
285
286 filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
287 # This python changes the datastore based on the contents of a file, so mark
288 # that dependency.
289 bb.parse.mark_dependency(d, filename)
290
291 with open(filename) as manifest_file:
292 manifest_str = manifest_file.read()
293 json_start = manifest_str.find('# EOC') + 6
294 manifest_file.seek(json_start)
295 manifest_str = manifest_file.read()
296 python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict)
297
298 # First set RPROVIDES for -native case
299 # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
300 pn = 'python3'
301 rprovides = (d.getVar('RPROVIDES') or "").split()
302
303 # ${PN}-misc-native is not in the manifest
304 rprovides.append(pn + '-misc-native')
305
306 for key in python_manifest:
307 pypackage = pn + '-' + key + '-native'
308 if pypackage not in rprovides:
309 rprovides.append(pypackage)
310
311 d.setVar('RPROVIDES:class-native', ' '.join(rprovides))
312
313 # Then work on the target
314 include_pycs = d.getVar('INCLUDE_PYCS')
315
316 packages = d.getVar('PACKAGES').split()
317 pn = d.getVar('PN')
318
319 newpackages=[]
320 for key in python_manifest:
321 pypackage = pn + '-' + key
322
323 if pypackage not in packages:
324 # We need to prepend, otherwise python-misc gets everything
325 # so we use a new variable
326 newpackages.append(pypackage)
327
328 # "Build" python's manifest FILES, RDEPENDS and SUMMARY
329 d.setVar('FILES:' + pypackage, '')
330 for value in python_manifest[key]['files']:
331 d.appendVar('FILES:' + pypackage, ' ' + value)
332
333 # Add cached files
334 if include_pycs == '1':
335 for value in python_manifest[key]['cached']:
336 d.appendVar('FILES:' + pypackage, ' ' + value)
337
338 for value in python_manifest[key]['rdepends']:
339 # Make it work with or without $PN
340 if '${PN}' in value:
341 value=value.split('-', 1)[1]
342 d.appendVar('RDEPENDS:' + pypackage, ' ' + pn + '-' + value)
343
344 for value in python_manifest[key].get('rrecommends', ()):
345 if '${PN}' in value:
346 value=value.split('-', 1)[1]
347 d.appendVar('RRECOMMENDS:' + pypackage, ' ' + pn + '-' + value)
348
349 d.setVar('SUMMARY:' + pypackage, python_manifest[key]['summary'])
350
351 # Prepending so to avoid python-misc getting everything
352 packages = newpackages + packages
353 d.setVar('PACKAGES', ' '.join(packages))
354 d.setVar('ALLOW_EMPTY:${PN}-modules', '1')
355 d.setVar('ALLOW_EMPTY:${PN}-pkgutil', '1')
356
357 if "pgo" in d.getVar("PACKAGECONFIG").split() and not bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d):
358 bb.fatal("pgo cannot be enabled as there is no qemu-usermode support for this architecture/machine")
359}
360
361# Files needed to create a new manifest
362
363do_create_manifest() {
364 # This task should be run with every new release of Python.
365 # We must ensure that PACKAGECONFIG enables everything when creating
366 # a new manifest, this is to base our new manifest on a complete
367 # native python build, containing all dependencies, otherwise the task
368 # wont be able to find the required files.
369 # e.g. BerkeleyDB is an optional build dependency so it may or may not
370 # be present, we must ensure it is.
371
372 cd ${WORKDIR}
373 # This needs to be executed by python-native and NOT by HOST's python
374 nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
375 cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
376}
377
378# bitbake python -c create_manifest
379# Make sure we have native python ready when we create a new manifest
380addtask do_create_manifest after do_patch do_prepare_recipe_sysroot
381
382# manual dependency additions
383RRECOMMENDS:${PN}-core:append:class-nativesdk = " nativesdk-python3-modules"
384RRECOMMENDS:${PN}-crypt:append:class-target = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
385RRECOMMENDS:${PN}-crypt:append:class-nativesdk = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
386
387# For historical reasons PN is empty and provided by python3-modules
388FILES:${PN} = ""
389RPROVIDES:${PN}-modules = "${PN}"
390
391FILES:${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
392FILES:${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
393
394# provide python-pyvenv from python3-venv
395RPROVIDES:${PN}-venv += "${MLPREFIX}python3-pyvenv"
396
397# package libpython3
398PACKAGES =+ "libpython3 libpython3-staticdev"
399FILES:libpython3 = "${libdir}/libpython*.so.*"
400FILES:libpython3-staticdev += "${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}-*/libpython${PYTHON_MAJMIN}.a"
401INSANE_SKIP:${PN}-dev += "dev-elf"
402INSANE_SKIP:${PN}-ptest = "dev-deps"
403
404# catch all the rest (unsorted)
405PACKAGES += "${PN}-misc"
406RDEPENDS:${PN}-misc += "\
Andrew Geissler8f840682023-07-21 09:09:43 -0500407 ${PN}-audio \
408 ${PN}-codecs \
Andrew Geissler517393d2023-01-13 08:55:19 -0600409 ${PN}-core \
410 ${PN}-email \
Andrew Geissler517393d2023-01-13 08:55:19 -0600411 ${PN}-numbers \
Andrew Geissler8f840682023-07-21 09:09:43 -0500412 ${PN}-pickle \
413 ${PN}-pydoc \
Andrew Geissler517393d2023-01-13 08:55:19 -0600414"
415RDEPENDS:${PN}-modules:append:class-target = " ${MLPREFIX}python3-misc"
416RDEPENDS:${PN}-modules:append:class-nativesdk = " ${MLPREFIX}python3-misc"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500417RDEPENDS:${PN}-modules:append:class-target = " ${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '${MLPREFIX}python3-gdbm', '', d)}"
Andrew Geissler517393d2023-01-13 08:55:19 -0600418FILES:${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload"
419
420# catch manpage
421PACKAGES += "${PN}-man"
422FILES:${PN}-man = "${datadir}/man"
423
424# See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395
425RDEPENDS:libpython3:append:libc-glibc = " libgcc"
426RDEPENDS:${PN}-ctypes:append:libc-glibc = " ${MLPREFIX}ldconfig"
Andrew Geissler8f840682023-07-21 09:09:43 -0500427RDEPENDS:${PN}-ptest = "${PN}-modules ${PN}-tests ${PN}-dev ${PN}-cgitb ${PN}-zipapp unzip bzip2 libgcc tzdata coreutils sed gcc g++ binutils"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -0500428RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-fr-fr locale-base-en-us locale-base-tr-tr locale-base-de-de"
Andrew Geissler517393d2023-01-13 08:55:19 -0600429RDEPENDS:${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${MLPREFIX}tk ${MLPREFIX}tk-lib', '', d)}"
430RDEPENDS:${PN}-idle += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${PN}-tkinter ${MLPREFIX}tcl', '', d)}"
431DEV_PKG_DEPENDENCY = ""
432RDEPENDS:${PN}-pydoc += "${PN}-io"
433
434RDEPENDS:${PN}-tests:append:class-target = " ${MLPREFIX}bash"
435RDEPENDS:${PN}-tests:append:class-nativesdk = " ${MLPREFIX}bash"
436
437# Python's tests contain large numbers of files we don't need in the recipe sysroots
438SYSROOT_PREPROCESS_FUNCS += " py3_sysroot_cleanup"
439py3_sysroot_cleanup () {
440 rm -rf ${SYSROOT_DESTDIR}${libdir}/python${PYTHON_MAJMIN}/test
441}