Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "The network configuration abstraction renderer" |
| 2 | DESCRIPTION = "Netplan is a utility for easily configuring networking on a \ |
| 3 | linux system. You simply create a YAML description of the required network \ |
| 4 | interfaces and what each should be configured to do. From this description \ |
| 5 | Netplan will generate all the necessary configuration for your chosen renderer \ |
| 6 | tool." |
| 7 | HOMEPAGE = "https://netplan.io" |
| 8 | SECTION = "net/misc" |
| 9 | |
| 10 | LICENSE = "GPLv3" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | SRCREV = "5d22e9d22c4a3724d27b80b0cd9b898ae8f59d2b" |
| 15 | PV = "0.98+git${SRCPV}" |
| 16 | |
| 17 | SRC_URI = " \ |
| 18 | git://github.com/CanonicalLtd/netplan.git \ |
| 19 | " |
| 20 | |
Andrew Geissler | 2ee498a | 2020-05-29 15:52:06 -0500 | [diff] [blame^] | 21 | DEPENDS = "glib-2.0 libyaml ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 22 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | RDEPENDS_${PN} = "python3 python3-core python3-pyyaml python3-netifaces python3-nose python3-coverage python3-pycodestyle python3-pyflakes util-linux-libuuid" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 24 | |
| 25 | inherit pkgconfig systemd |
| 26 | |
| 27 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 28 | |
| 29 | EXTRA_OEMAKE = "generate" |
| 30 | EXTRA_OEMAKE =+ "${@bb.utils.contains('DISTRO_FEATURES','systemd','netplan-dbus dbus/io.netplan.Netplan.service','',d)}" |
| 31 | |
| 32 | do_install() { |
| 33 | install -d ${D}${sbindir} ${D}${base_libdir}/netplan ${D}${datadir}/netplan/netplan/cli/commands ${D}${sysconfdir}/netplan |
| 34 | install -m 755 ${S}/generate ${D}${base_libdir}/netplan/ |
| 35 | install -m 644 ${S}/netplan/*.py ${D}${datadir}/netplan/netplan |
| 36 | install -m 644 ${S}/netplan/cli/*.py ${D}${datadir}/netplan/netplan/cli |
| 37 | install -m 644 ${S}/netplan/cli/commands/*.py ${D}${datadir}/netplan/netplan/cli/commands |
| 38 | install -m 755 ${S}/src/netplan.script ${D}${datadir}/netplan/ |
| 39 | ln -srf ${D}${datadir}/netplan/netplan.script ${D}${sbindir}/netplan |
| 40 | |
| 41 | install -d ${D}/${systemd_unitdir}/system ${D}${systemd_unitdir}/system-generators |
| 42 | install -m 644 ${S}/src/netplan-wpa@.service ${D}${systemd_unitdir}/system/ |
| 43 | ln -srf ${D}/${base_libdir}/netplan/generate ${D}${systemd_unitdir}/system-generators |
| 44 | |
| 45 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 46 | install -d ${D}${datadir}/dbus-1/system.d ${D}${datadir}/dbus-1/system-services |
| 47 | install -m 755 ${S}/netplan-dbus ${D}${base_libdir}/netplan |
| 48 | install -m 644 ${S}/dbus/io.netplan.Netplan.conf ${D}${datadir}/dbus-1/system.d |
| 49 | install -m 644 ${S}/dbus/io.netplan.Netplan.service ${D}${datadir}/dbus-1/system-services |
| 50 | fi |
| 51 | } |
| 52 | |
| 53 | SYSTEMD_SERVICE_${PN} = "netplan-wpa@.service" |
| 54 | SYSTEMD_AUTO_ENABLE = "disable" |
| 55 | |
| 56 | PACKAGES += "${PN}-dbus" |
| 57 | |
| 58 | FILES_${PN} = "${sbindir} ${base_libdir}/netplan/generate ${datadir}/netplan ${sysconfdir}/netplan ${systemd_unitdir}" |
| 59 | FILES_${PN}-dbus = "${base_libdir}/netplan/netplan-dbus ${datadir}/dbus-1" |