blob: 2d9ec079a4c5195c8e7e7d9e81d39d3835d69aa1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A Python library for building configuration shells"
2DESCRIPTION = "configshell-fb is a Python library that provides a framework for \
3building simple but nice CLI-based applications. This runs with Python 2 and \
42to3 is run by setup.py to run on Python 3."
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=1dece7821bf3fd70fe1309eaa37d52a2"
8
9SRC_URI = "git://github.com/open-iscsi/configshell-fb.git;protocol=https;branch=master"
10SRCREV = "da8f0cef114e7343a7ae96ff1db7c8c574f819be"
11
12S = "${WORKDIR}/git"
13
14inherit setuptools3
15
16RDEPENDS_${PN} += "python3-modules python3-fcntl python3-six"