Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Python WBEM Client and Provider Interface" |
| 2 | DESCRIPTION = "\ |
| 3 | A Python library for making CIM (Common Information Model) operations over \ |
| 4 | HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \ |
| 5 | WBEM client should be easy to use and not necessarily require a large amount \ |
| 6 | of programming knowledge. It is suitable for a large range of tasks from \ |
| 7 | simply poking around to writing web and GUI applications. \ |
| 8 | \ |
| 9 | WBEM, or Web Based Enterprise Management is a manageability protocol, like \ |
| 10 | SNMP, standardised by the Distributed Management Task Force (DMTF) available \ |
| 11 | at http://www.dmtf.org/standards/wbem. \ |
| 12 | \ |
| 13 | It also provides a Python provider interface, and is the fastest and easiest \ |
| 14 | way to write providers on the planet." |
| 15 | HOMEPAGE = "http://pywbem.sf.net/" |
| 16 | LICENSE = "LGPLv2" |
| 17 | LIC_FILES_CHKSUM = "file://pywbem/LICENSE.txt;md5=fbc093901857fcd118f065f900982c24" |
| 18 | SECTION = "Development/Libraries" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | DEPENDS = "python-m2crypto-native python-typing-native" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | SRC_URI = "http://jaist.dl.sourceforge.net/project/${BPN}/${BPN}/${BP}/${BP}-dev.r704.zip" |
| 21 | SRC_URI[md5sum] = "84072451dcdd1aa9ee82363848faf7ad" |
| 22 | SRC_URI[sha256sum] = "898035866d3cc741bbcd62c4ac26e633ad07b7c11d89db2472b9f923f3fd3ed8" |
| 23 | |
| 24 | S = "${WORKDIR}/${BP}-dev" |
| 25 | |
| 26 | inherit setuptools python-dir |
| 27 | |
| 28 | do_install_append() { |
| 29 | mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli |
| 30 | mv ${D}${bindir}/mof_compiler.py ${D}${bindir}/mofcomp |
| 31 | |
| 32 | rm ${D}${libdir}/python2.7/site-packages/${BPN}/wbemcli.py* |
| 33 | rm ${D}${libdir}/python2.7/site-packages/${BPN}/mof_compiler.py* |
| 34 | } |
| 35 | |
| 36 | BBCLASSEXTEND = "native" |