blob: f4c0654354705dd0e0dcb05e7ab5d94a82a8c0f0 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001KBRANCH ?= "v6.4/standard/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# CVE exclusions
6include recipes-kernel/linux/cve-exclusion.inc
7include recipes-kernel/linux/cve-exclusion_6.4.inc
8
9SRCREV_machine ?= "ef91ff6a4be36037808af1ca786fdd557f265a1d"
10SRCREV_meta ?= "13efe44fe9dd2626eaf6552288ea31770ec71cf1"
11
12# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
13# get the <version>/base branch, which is pure upstream -stable, and the same
14# meta SRCREV as the linux-yocto-standard builds. Select your version using the
15# normal PREFERRED_VERSION settings.
16BBCLASSEXTEND = "devupstream:target"
17SRCREV_machine:class-devupstream ?= "ae4e4fc35b4258626644c162a702e2bce2b79190"
18PN:class-devupstream = "linux-yocto-upstream"
19KBRANCH:class-devupstream = "v6.4/base"
20
21SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH};protocol=https \
22 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.4;destsuffix=${KMETA};protocol=https"
23
24LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
25LINUX_VERSION ?= "6.4.16"
26
27PV = "${LINUX_VERSION}+git"
28
29KMETA = "kernel-meta"
30KCONF_BSP_AUDIT_LEVEL = "1"
31
32# Functionality flags
33KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
34KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}"
35KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
36KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc", "", d)}"
37KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc", "", d)}"
38
39SRC_URI:append:aarch64 = " file://0001-arm64-defconfig-remove-CONFIG_COMMON_CLK_NPCM8XX-y.patch"