blob: bb1f53624a0922cf302ab94213849513e1739de6 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Monitor for system resources and process activity"
2DESCRIPTION = "Atop is an ASCII full-screen performance monitor for Linux that \
3is capable of reporting the activity of all processes (even if processes have \
4finished during the interval), daily logging of system and process activity for \
5long-term analysis, highlighting overloaded system resources by using colors, \
6etc. At regular intervals, it shows system-level activity related to the CPU, \
7memory, swap, disks (including LVM) and network layers, and for every process \
8(and thread) it shows e.g. the CPU utilization, memory growth, disk \
9utilization, priority, username, state, and exit code."
10HOMEPAGE = "http://www.atoptool.nl"
11SECTION = "console/utils"
12
Andrew Geissler9aee5002022-03-30 16:27:02 +000013LICENSE = "GPL-2.0-only"
Brad Bishop19323692019-04-05 15:28:33 -040014LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
15
16DEPENDS = "ncurses zlib"
17
18SRC_URI = "http://www.atoptool.nl/download/${BP}.tar.gz \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'file://volatiles.atop.conf', 'file://volatiles.99_atop', d)} \
20 file://fix-permissions.patch \
21 file://sysvinit-implement-status.patch \
22 file://0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch \
23 "
24SRC_URI[md5sum] = "1077da884ed94f2bc3c81ac3ab970436"
25SRC_URI[sha256sum] = "be1c010a77086b7d98376fce96514afcd73c3f20a8d1fe01520899ff69a73d69"
26
Patrick Williams2a254922023-08-11 09:48:11 -050027CVE_STATUS[CVE-2011-3618] = "fixed-version: The CPE in the NVD database doesn't reflect correctly the vulnerable versions."
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050028
Brad Bishop19323692019-04-05 15:28:33 -040029do_compile() {
30 oe_runmake all
31}
32
33do_install() {
34 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
35 make DESTDIR=${D} VERS=${PV} SYSDPATH=${systemd_system_unitdir} \
36 PMPATHD=${systemd_unitdir}/system-sleep systemdinstall
37 install -d ${D}${sysconfdir}/tmpfiles.d
38 install -m 644 ${WORKDIR}/volatiles.atop.conf ${D}${sysconfdir}/tmpfiles.d/atop.conf
39 rm -f ${D}${systemd_system_unitdir}/atopacct.service
40 else
41 make DESTDIR=${D} VERS=${PV} sysvinstall
42 install -d ${D}${sysconfdir}/default/volatiles
43 install -m 644 ${WORKDIR}/volatiles.99_atop ${D}${sysconfdir}/default/volatiles/99_atop
44 rm -f ${D}${sysconfdir}/init.d/atopacct
45 fi
46
Andrew Geissler595f6302022-01-24 19:11:47 +000047 # /var/log/atop will be created in runtime
48 rm -rf ${D}${localstatedir}/log
49 rmdir --ignore-fail-on-non-empty ${D}${localstatedir}
50
Brad Bishop19323692019-04-05 15:28:33 -040051 # remove atopacct related files
52 rm -rf ${D}${sbindir} ${D}${mandir}/man8
53}
54
55inherit systemd
56
Patrick Williams213cb262021-08-07 19:21:33 -050057SYSTEMD_SERVICE:${PN} = "atop.service atopgpu.service"
Brad Bishop19323692019-04-05 15:28:33 -040058SYSTEMD_AUTO_ENABLE = "disable"
59
Patrick Williams213cb262021-08-07 19:21:33 -050060FILES:${PN} += "${systemd_unitdir}/system-sleep"
Brad Bishop19323692019-04-05 15:28:33 -040061
Patrick Williams213cb262021-08-07 19:21:33 -050062RDEPENDS:${PN} = "procps"