Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "LLVM compiler framework (packaged with rust)" |
| 2 | LICENSE ?= "Apache-2.0-with-LLVM-exception" |
| 3 | HOMEPAGE = "http://www.rust-lang.org" |
| 4 | |
| 5 | # check src/llvm-project/llvm/CMakeLists.txt for llvm version in use |
| 6 | # |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 7 | LLVM_RELEASE = "16.0.2" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 8 | |
| 9 | require rust-source.inc |
| 10 | |
| 11 | SRC_URI += "file://0002-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \ |
| 12 | file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \ |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 13 | file://0003-llvm-fix-include-benchmarks.patch;striplevel=2" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 14 | |
| 15 | S = "${RUSTSRC}/src/llvm-project/llvm" |
| 16 | |
| 17 | LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=8a15a0759ef07f2682d2ba4b893c9afe" |
| 18 | |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 19 | inherit cmake |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 20 | |
| 21 | DEPENDS += "ninja-native rust-llvm-native" |
| 22 | |
| 23 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 24 | ARM_INSTRUCTION_SET:armv4t = "arm" |
| 25 | |
| 26 | # rustc_llvm with debug info is not recognized as a valid crate that's |
| 27 | # generated by rust-llvm-native. |
| 28 | CFLAGS:remove = "-g" |
| 29 | CXXFLAGS:remove = "-g" |
| 30 | |
| 31 | LLVM_DIR = "llvm${LLVM_RELEASE}" |
| 32 | |
| 33 | EXTRA_OECMAKE = " \ |
| 34 | -DCMAKE_BUILD_TYPE=Release \ |
| 35 | -DLLVM_TARGETS_TO_BUILD='ARM;AArch64;Mips;PowerPC;RISCV;X86' \ |
| 36 | -DLLVM_BUILD_DOCS=OFF \ |
| 37 | -DLLVM_ENABLE_TERMINFO=OFF \ |
| 38 | -DLLVM_ENABLE_ZLIB=OFF \ |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 39 | -DLLVM_ENABLE_ZSTD=OFF \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 40 | -DLLVM_ENABLE_LIBXML2=OFF \ |
| 41 | -DLLVM_ENABLE_FFI=OFF \ |
| 42 | -DLLVM_INSTALL_UTILS=ON \ |
| 43 | -DLLVM_BUILD_EXAMPLES=OFF \ |
| 44 | -DLLVM_INCLUDE_EXAMPLES=OFF \ |
| 45 | -DLLVM_BUILD_TESTS=OFF \ |
| 46 | -DLLVM_INCLUDE_TESTS=OFF \ |
| 47 | -DLLVM_TARGET_ARCH=${TARGET_ARCH} \ |
| 48 | -DCMAKE_INSTALL_PREFIX:PATH=${libdir}/llvm-rust \ |
| 49 | " |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 50 | |
| 51 | # Forcibly disable the detection of these packages as otherwise |
| 52 | # it will look at the host Python install |
| 53 | EXTRA_OECMAKE += "\ |
| 54 | -DPY_PYGMENTS_FOUND=OFF \ |
| 55 | -DPY_PYGMENTS_LEXERS_C_CPP_FOUND=OFF \ |
| 56 | -DPY_YAML_FOUND=OFF \ |
| 57 | " |
| 58 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 59 | EXTRA_OECMAKE:append:class-target = "\ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 60 | -DLLVM_BUILD_TOOLS=OFF \ |
| 61 | -DLLVM_TABLEGEN=${STAGING_LIBDIR_NATIVE}/llvm-rust/bin/llvm-tblgen \ |
| 62 | -DLLVM_CONFIG_PATH=${STAGING_LIBDIR_NATIVE}/llvm-rust/bin/llvm-config \ |
| 63 | " |
| 64 | |
| 65 | EXTRA_OECMAKE:append:class-nativesdk = "\ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 66 | -DLLVM_BUILD_TOOLS=OFF \ |
| 67 | -DLLVM_TABLEGEN=${STAGING_LIBDIR_NATIVE}/llvm-rust/bin/llvm-tblgen \ |
| 68 | -DLLVM_CONFIG_PATH=${STAGING_LIBDIR_NATIVE}/llvm-rust/bin/llvm-config \ |
| 69 | " |
| 70 | |
| 71 | # The debug symbols are huge here (>2GB) so suppress them since they |
| 72 | # provide almost no value. If you really need them then override this |
| 73 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
| 74 | |
| 75 | export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_LIBDIR}/llvm-rust/bin/llvm-config" |
| 76 | |
| 77 | do_install:append () { |
| 78 | # we don't need any of this stuff to build Rust |
| 79 | rm -rf "${D}/usr/lib/cmake" |
| 80 | } |
| 81 | |
| 82 | PACKAGES =+ "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-liblto" |
| 83 | |
| 84 | # Add the extra locations to avoid the complaints about unpackaged files |
| 85 | FILES:${PN}-bugpointpasses = "${libdir}/llvm-rust/lib/BugpointPasses.so" |
| 86 | FILES:${PN}-llvmhello = "${libdir}/llvm-rust/lib/LLVMHello.so" |
| 87 | FILES:${PN}-liblto = "${libdir}/llvm-rust/lib/libLTO.so.*" |
| 88 | FILES:${PN}-staticdev =+ "${libdir}/llvm-rust/*/*.a" |
| 89 | FILES:${PN} += "${libdir}/libLLVM*.so.* ${libdir}/llvm-rust/lib/*.so.* ${libdir}/llvm-rust/bin" |
| 90 | FILES:${PN}-dev += "${datadir}/llvm ${libdir}/llvm-rust/lib/*.so ${libdir}/llvm-rust/include ${libdir}/llvm-rust/share ${libdir}/llvm-rust/lib/cmake" |
| 91 | |
| 92 | BBCLASSEXTEND = "native nativesdk" |