Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" |
| 2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ |
| 3 | OS-independent reference implementation of the Advanced Configuration and \ |
| 4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ |
| 5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ |
| 6 | subsystem, and a small set of tools to assist in developing and debugging \ |
| 7 | ACPI tables." |
| 8 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 9 | HOMEPAGE = "https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/overview.html" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 10 | SECTION = "console/tools" |
| 11 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 12 | LICENSE = "Intel | BSD-3-Clause | GPL-2.0-only" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 13 | LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=79a69059b499bccc70a484459549758f" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | |
| 15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 16 | |
| 17 | DEPENDS = "m4-native flex-native bison-native" |
| 18 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 19 | SRC_URI = "https://downloadmirror.intel.com/783534/acpica-unix-${PV}.tar.gz" |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 20 | SRC_URI[sha256sum] = "86876a745e3d224dcfd222ed3de465b47559e85811df2db9820ef09a9dff5cce" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 21 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 22 | UPSTREAM_CHECK_URI = "https://www.intel.com/content/www/us/en/download/776303/acpi-component-architecture-downloads-unix-format-source-code-and-build-environment-with-an-intel-license.html" |
| 23 | UPSTREAM_VERSION_UNKNOWN = "1" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 24 | |
| 25 | S = "${WORKDIR}/acpica-unix-${PV}" |
| 26 | |
| 27 | inherit update-alternatives |
| 28 | |
| 29 | ALTERNATIVE_PRIORITY = "100" |
| 30 | ALTERNATIVE:${PN} = "acpixtract acpidump" |
| 31 | |
| 32 | EXTRA_OEMAKE = "CC='${CC}' \ |
| 33 | OPT_CFLAGS=-Wall \ |
| 34 | DESTDIR=${D} \ |
| 35 | PREFIX=${prefix} \ |
| 36 | INSTALLDIR=${bindir} \ |
| 37 | INSTALLFLAGS= \ |
| 38 | YACC=bison \ |
| 39 | YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \ |
| 40 | " |
| 41 | |
| 42 | do_install() { |
| 43 | oe_runmake install |
| 44 | } |
| 45 | |
| 46 | # iasl*.bb is a subset of this recipe, so RREPLACE it |
| 47 | PROVIDES = "iasl" |
| 48 | RPROVIDES:${PN} += "iasl" |
| 49 | RREPLACES:${PN} += "iasl" |
| 50 | RCONFLICTS:${PN} += "iasl" |
| 51 | |
| 52 | BBCLASSEXTEND = "native" |