Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Matchbox lightweight window manager" |
| 2 | HOMEPAGE = "http://matchbox-project.org" |
| 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 4 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-or-later" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://src/wm.h;endline=21;md5=ce20617ac10f26045cc57b8d977ab552 \ |
| 7 | file://src/main.c;endline=21;md5=508f280276140250ce483e0a44f7a9ec \ |
| 8 | file://src/wm.c;endline=21;md5=f54584fb0d48cfc2e6876e0f0e272e6c" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | |
| 10 | SECTION = "x11/wm" |
| 11 | DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf libxcursor libxfixes" |
| 12 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 13 | SRCREV = "ce8c1053270d960a7235ab5c3435f707541810a4" |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 14 | SRC_URI = "git://git.yoctoproject.org/matchbox-window-manager;branch=master;protocol=https \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 15 | file://kbdconfig" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 19 | inherit autotools pkgconfig features_check |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | # depends on virtual/libx11 |
| 21 | REQUIRED_DISTRO_FEATURES = "x11" |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | FILES:${PN} = "${bindir}/* \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | ${datadir}/matchbox \ |
| 25 | ${sysconfdir}/matchbox \ |
| 26 | ${datadir}/themes/blondie/matchbox \ |
| 27 | ${datadir}/themes/Default/matchbox \ |
| 28 | ${datadir}/themes/MBOpus/matchbox" |
| 29 | |
| 30 | EXTRA_OECONF = " --enable-startup-notification \ |
| 31 | --disable-xrm \ |
| 32 | --enable-expat \ |
| 33 | --with-expat-lib=${STAGING_LIBDIR} \ |
| 34 | --with-expat-includes=${STAGING_INCDIR}" |
| 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | do_install:prepend() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 37 | install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig |
| 38 | } |