Tim Lee | 251ad11 | 2022-09-28 17:24:24 +0800 | [diff] [blame] | 1 | SUMMARY = "Primary bootloader for NPCM8XX (Arbel) devices" |
| 2 | DESCRIPTION = "Primary bootloader for NPCM8XX (Arbel) devices" |
| 3 | HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm8xx-bootblock" |
| 4 | LICENSE = "GPL-2.0-only" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=650b869bd8ff2aed59c62bad2a22a821" |
| 6 | |
| 7 | FILENAME = "arbel_a35_bootblock_${PV}.bin" |
| 8 | |
| 9 | S = "${WORKDIR}" |
| 10 | |
| 11 | SRCREV = "4002b2f086f6d2177ec36bed507241386d604f6b" |
| 12 | SRC_URI = " \ |
| 13 | https://github.com/Nuvoton-Israel/npcm8xx-bootblock/blob/${SRCREV}/LICENSE;name=lic \ |
| 14 | https://github.com/Nuvoton-Israel/npcm8xx-bootblock/releases/download/A35_BootBlock_${PV}/arbel_a35_bootblock.bin;downloadfilename=${FILENAME};name=bin \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[lic.sha256sum] = "7c34d28e784b202aa4998f477fd0aa9773146952d7f6fa5971369fcdda59cf48" |
| 18 | SRC_URI[bin.sha256sum] = "9d58a1dbe2ee156780b53f2539cf5d48436a83390ad9db340acc503aef7de72d" |
| 19 | |
| 20 | inherit deploy |
| 21 | |
| 22 | do_deploy () { |
| 23 | install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/arbel_a35_bootblock.bin |
| 24 | } |
| 25 | |
| 26 | addtask deploy before do_build after do_compile |