blob: 8ba1b60995f0d06f34301d078c8c873017999012 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001# Copyright (c) 2012-2014 LG Electronics, Inc.
2SUMMARY = "c-ares is a C library that resolves names asynchronously."
3HOMEPAGE = "http://daniel.haxx.se/projects/c-ares/"
4SECTION = "libs"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fdbc58a6da11a9f68aa73c453818decc"
7
8SRC_URI = "git://github.com/c-ares/c-ares.git;branch=main;protocol=https"
9SRCREV = "36466bb240661fa8fdc2ffa47d229d92ac762286"
10
11UPSTREAM_CHECK_GITTAGREGEX = "cares-(?P<pver>\d+_(\d_?)+)"
12
13S = "${WORKDIR}/git"
14
15inherit cmake pkgconfig
16
17PACKAGES =+ "${PN}-utils"
18
19FILES:${PN}-utils = "${bindir}"
20
21BBCLASSEXTEND = "native nativesdk"