Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Count blank lines, comment lines, and physical lines of source code \ |
| 2 | in many programming languages." |
| 3 | |
| 4 | LICENSE="GPL-2.0-only" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2" |
| 6 | |
| 7 | SRC_URI = "https://github.com/AlDanial/cloc/releases/download/v${PV}/${BP}.tar.gz" |
| 8 | SRC_URI[sha256sum] = "5fe0b159eb75718df7308a4f61470eaddf82170733929999e37a3fbb4651cf8a" |
| 9 | |
| 10 | UPSTREAM_CHECK_URI = "https://github.com/AlDanial/${BPN}/releases" |
| 11 | |
| 12 | do_configure[noexec] = "1" |
| 13 | do_compile[noexec] = "1" |
| 14 | |
| 15 | do_install() { |
| 16 | install -D -m 0755 ${S}/cloc ${D}${bindir}/cloc |
| 17 | } |
| 18 | |
| 19 | RDEPENDS:${PN} = "perl perl-modules" |