Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 1 | SUMMARY = "The PyPA recommended tool for installing Python packages" |
| 2 | HOMEPAGE = "https://pypi.org/project/pip" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT & Apache-2.0 & MPL-2.0 & LGPL-2.1-only & BSD-3-Clause & PSF-2.0 & BSD-2-Clause" |
| 5 | LIC_FILES_CHKSUM = "\ |
| 6 | file://LICENSE.txt;md5=63ec52baf95163b597008bb46db68030 \ |
| 7 | file://src/pip/_vendor/cachecontrol/LICENSE.txt;md5=6572692148079ebbbd800be4b9f36c6d \ |
| 8 | file://src/pip/_vendor/certifi/LICENSE;md5=67da0714c3f9471067b729eca6c9fbe8 \ |
| 9 | file://src/pip/_vendor/chardet/LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343 \ |
| 10 | file://src/pip/_vendor/colorama/LICENSE.txt;md5=b4936429a56a652b84c5c01280dcaa26 \ |
| 11 | file://src/pip/_vendor/distlib/LICENSE.txt;md5=f6a11430d5cd6e2cd3832ee94f22ddfc \ |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 12 | file://src/pip/_vendor/distro/LICENSE;md5=d2794c0df5b907fdace235a619d80314 \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 13 | file://src/pip/_vendor/html5lib/LICENSE;md5=1ba5ada9e6fead1fdc32f43c9f10ba7c \ |
| 14 | file://src/pip/_vendor/idna/LICENSE.md;md5=239668a7c6066d9e0c5382e9c8c6c0e1 \ |
| 15 | file://src/pip/_vendor/msgpack/COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751 \ |
| 16 | file://src/pip/_vendor/packaging/LICENSE;md5=faadaedca9251a90b205c9167578ce91 \ |
| 17 | file://src/pip/_vendor/packaging/LICENSE.APACHE;md5=2ee41112a44fe7014dce33e26468ba93 \ |
| 18 | file://src/pip/_vendor/pep517/LICENSE;md5=aad69c93f605003e3342b174d9b0708c \ |
| 19 | file://src/pip/_vendor/pkg_resources/LICENSE;md5=9a33897f1bca1160d7aad3835152e158 \ |
| 20 | file://src/pip/_vendor/platformdirs/LICENSE.txt;md5=282c970bb844954c8535dd6e9733db7f \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 21 | file://src/pip/_vendor/pygments/LICENSE;md5=98419e351433ac106a24e3ad435930bc \ |
| 22 | file://src/pip/_vendor/pyparsing/LICENSE;md5=657a566233888513e1f07ba13e2f47f1 \ |
| 23 | file://src/pip/_vendor/requests/LICENSE;md5=34400b68072d710fecd0a2940a0d1658 \ |
| 24 | file://src/pip/_vendor/resolvelib/LICENSE;md5=78e1c0248051c32a38a7f820c30bd7a5 \ |
| 25 | file://src/pip/_vendor/rich/LICENSE;md5=b5f0b94fbc94f5ad9ae4efcf8a778303 \ |
| 26 | file://src/pip/_vendor/six.LICENSE;md5=43cfc9e4ac0e377acfb9b76f56b8415d \ |
| 27 | file://src/pip/_vendor/tenacity/LICENSE;md5=175792518e4ac015ab6696d16c4f607e \ |
| 28 | file://src/pip/_vendor/tomli/LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5 \ |
| 29 | file://src/pip/_vendor/typing_extensions.LICENSE;md5=64fc2b30b67d0a8423c250e0386ed72f \ |
| 30 | file://src/pip/_vendor/urllib3/LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c \ |
| 31 | file://src/pip/_vendor/webencodings/LICENSE;md5=81fb24cd7823cce23b69f721993dce4d \ |
| 32 | " |
| 33 | |
| 34 | inherit pypi python_setuptools_build_meta |
| 35 | |
| 36 | SRC_URI += "file://0001-change-shebang-to-python3.patch" |
| 37 | SRC_URI += "file://no_shebang_mangling.patch" |
| 38 | SRC_URI += "file://reproducible.patch" |
| 39 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 40 | SRC_URI[sha256sum] = "6d55b27e10f506312894a87ccc59f280136bad9061719fac9101bdad5a6bce69" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 41 | |
| 42 | do_install:append() { |
| 43 | rm -f ${D}/${bindir}/pip |
| 44 | } |
| 45 | |
| 46 | RDEPENDS:${PN} = "\ |
| 47 | python3-compile \ |
| 48 | python3-io \ |
| 49 | python3-html \ |
| 50 | python3-json \ |
| 51 | python3-multiprocessing \ |
| 52 | python3-netserver \ |
| 53 | python3-setuptools \ |
| 54 | python3-unixadmin \ |
| 55 | python3-xmlrpc \ |
| 56 | python3-pickle \ |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 57 | python3-distutils \ |
| 58 | python3-image \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 59 | " |
| 60 | |
| 61 | BBCLASSEXTEND = "native nativesdk" |
| 62 | |
| 63 | # This used to use the bootstrap install which didn't compile. Until we bump the |
| 64 | # tmpdir version we can't compile the native otherwise the sysroot unpack fails |
| 65 | INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode" |