Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | python __anonymous() { |
| 2 | if "linux-raspberrypi-dev" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"): |
| 3 | msg = "Skipping linux-raspberrypi-dev as it is not the preferred " + \ |
| 4 | "provider of virtual/kernel." |
| 5 | raise bb.parse.SkipRecipe(msg) |
| 6 | } |
| 7 | |
| 8 | FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:" |
| 9 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 10 | LINUX_VERSION ?= "4.16" |
| 11 | LINUX_RPI_DEV_BRANCH ?= "rpi-4.16.y" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | |
| 13 | SRCREV = "${AUTOREV}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | SRC_URI = " \ |
| 15 | git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RPI_DEV_BRANCH} \ |
| 16 | file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \ |
| 17 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | require linux-raspberrypi.inc |
| 19 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | # Disable version check so that we don't have to edit this recipe every time |
| 21 | # upstream bumps the version |
| 22 | KERNEL_VERSION_SANITY_SKIP = "1" |