Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # ex:ts=4:sw=4:sts=4:et |
| 2 | # -*- tab-width: 4; c-basic-offset: 4; indent-tabs-mode: nil -*- |
| 3 | # |
| 4 | # This bbclass is used for creating archive for: |
| 5 | # 1) original (or unpacked) source: ARCHIVER_MODE[src] = "original" |
| 6 | # 2) patched source: ARCHIVER_MODE[src] = "patched" (default) |
| 7 | # 3) configured source: ARCHIVER_MODE[src] = "configured" |
| 8 | # 4) The patches between do_unpack and do_patch: |
| 9 | # ARCHIVER_MODE[diff] = "1" |
| 10 | # And you can set the one that you'd like to exclude from the diff: |
| 11 | # ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches" |
| 12 | # 5) The environment data, similar to 'bitbake -e recipe': |
| 13 | # ARCHIVER_MODE[dumpdata] = "1" |
| 14 | # 6) The recipe (.bb and .inc): ARCHIVER_MODE[recipe] = "1" |
| 15 | # 7) Whether output the .src.rpm package: |
| 16 | # ARCHIVER_MODE[srpm] = "1" |
| 17 | # 8) Filter the license, the recipe whose license in |
| 18 | # COPYLEFT_LICENSE_INCLUDE will be included, and in |
| 19 | # COPYLEFT_LICENSE_EXCLUDE will be excluded. |
| 20 | # COPYLEFT_LICENSE_INCLUDE = 'GPL* LGPL*' |
| 21 | # COPYLEFT_LICENSE_EXCLUDE = 'CLOSED Proprietary' |
| 22 | # 9) The recipe type that will be archived: |
| 23 | # COPYLEFT_RECIPE_TYPES = 'target' |
| 24 | # |
| 25 | |
| 26 | # Don't filter the license by default |
| 27 | COPYLEFT_LICENSE_INCLUDE ?= '' |
| 28 | COPYLEFT_LICENSE_EXCLUDE ?= '' |
| 29 | # Create archive for all the recipe types |
| 30 | COPYLEFT_RECIPE_TYPES ?= 'target native nativesdk cross crosssdk cross-canadian' |
| 31 | inherit copyleft_filter |
| 32 | |
| 33 | ARCHIVER_MODE[srpm] ?= "0" |
| 34 | ARCHIVER_MODE[src] ?= "patched" |
| 35 | ARCHIVER_MODE[diff] ?= "0" |
| 36 | ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches" |
| 37 | ARCHIVER_MODE[dumpdata] ?= "0" |
| 38 | ARCHIVER_MODE[recipe] ?= "0" |
| 39 | |
| 40 | DEPLOY_DIR_SRC ?= "${DEPLOY_DIR}/sources" |
| 41 | ARCHIVER_TOPDIR ?= "${WORKDIR}/deploy-sources" |
| 42 | ARCHIVER_OUTDIR = "${ARCHIVER_TOPDIR}/${TARGET_SYS}/${PF}/" |
| 43 | ARCHIVER_WORKDIR = "${WORKDIR}/archiver-work/" |
| 44 | |
| 45 | do_dumpdata[dirs] = "${ARCHIVER_OUTDIR}" |
| 46 | do_ar_recipe[dirs] = "${ARCHIVER_OUTDIR}" |
| 47 | do_ar_original[dirs] = "${ARCHIVER_OUTDIR} ${ARCHIVER_WORKDIR}" |
| 48 | do_deploy_archives[dirs] = "${WORKDIR}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 49 | |
| 50 | # This is a convenience for the shell script to use it |
| 51 | |
| 52 | |
| 53 | python () { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 54 | pn = d.getVar('PN') |
| 55 | assume_provided = (d.getVar("ASSUME_PROVIDED") or "").split() |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 56 | if pn in assume_provided: |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 57 | for p in d.getVar("PROVIDES").split(): |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 58 | if p != pn: |
| 59 | pn = p |
| 60 | break |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 61 | |
| 62 | included, reason = copyleft_should_include(d) |
| 63 | if not included: |
| 64 | bb.debug(1, 'archiver: %s is excluded: %s' % (pn, reason)) |
| 65 | return |
| 66 | else: |
| 67 | bb.debug(1, 'archiver: %s is included: %s' % (pn, reason)) |
| 68 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 69 | |
| 70 | # glibc-locale: do_fetch, do_unpack and do_patch tasks have been deleted, |
| 71 | # so avoid archiving source here. |
| 72 | if pn.startswith('glibc-locale'): |
| 73 | return |
| 74 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 75 | # We just archive gcc-source for all the gcc related recipes |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 76 | if d.getVar('BPN') in ['gcc', 'libgcc'] \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 77 | and not pn.startswith('gcc-source'): |
| 78 | bb.debug(1, 'archiver: %s is excluded, covered by gcc-source' % pn) |
| 79 | return |
| 80 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 81 | ar_src = d.getVarFlag('ARCHIVER_MODE', 'src') |
| 82 | ar_dumpdata = d.getVarFlag('ARCHIVER_MODE', 'dumpdata') |
| 83 | ar_recipe = d.getVarFlag('ARCHIVER_MODE', 'recipe') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 84 | |
| 85 | if ar_src == "original": |
| 86 | d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_original' % pn) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 87 | # 'patched' and 'configured' invoke do_unpack_and_patch because |
| 88 | # do_ar_patched resp. do_ar_configured depend on it, but for 'original' |
| 89 | # we have to add it explicitly. |
| 90 | if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1': |
| 91 | d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_unpack_and_patch' % pn) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 92 | elif ar_src == "patched": |
| 93 | d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_patched' % pn) |
| 94 | elif ar_src == "configured": |
| 95 | # We can't use "addtask do_ar_configured after do_configure" since it |
| 96 | # will cause the deptask of do_populate_sysroot to run not matter what |
| 97 | # archives we need, so we add the depends here. |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 98 | |
| 99 | # There is a corner case with "gcc-source-${PV}" recipes, they don't have |
| 100 | # the "do_configure" task, so we need to use "do_preconfigure" |
| 101 | if pn.startswith("gcc-source-"): |
| 102 | d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_preconfigure' % pn) |
| 103 | else: |
| 104 | d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_configure' % pn) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 105 | d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_configured' % pn) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 106 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 107 | elif ar_src: |
| 108 | bb.fatal("Invalid ARCHIVER_MODE[src]: %s" % ar_src) |
| 109 | |
| 110 | if ar_dumpdata == "1": |
| 111 | d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_dumpdata' % pn) |
| 112 | |
| 113 | if ar_recipe == "1": |
| 114 | d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_recipe' % pn) |
| 115 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 116 | # Output the SRPM package |
| 117 | if d.getVarFlag('ARCHIVER_MODE', 'srpm') == "1" and d.getVar('PACKAGES'): |
| 118 | if "package_rpm" in d.getVar('PACKAGE_CLASSES'): |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 119 | d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_package_write_rpm' % pn) |
| 120 | if ar_dumpdata == "1": |
| 121 | d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_dumpdata' % pn) |
| 122 | if ar_recipe == "1": |
| 123 | d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_recipe' % pn) |
| 124 | if ar_src == "original": |
| 125 | d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_original' % pn) |
| 126 | elif ar_src == "patched": |
| 127 | d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_patched' % pn) |
| 128 | elif ar_src == "configured": |
| 129 | d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_configured' % pn) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 130 | else: |
| 131 | bb.fatal("ARCHIVER_MODE[srpm] needs package_rpm in PACKAGE_CLASSES") |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 132 | } |
| 133 | |
| 134 | # Take all the sources for a recipe and puts them in WORKDIR/archiver-work/. |
| 135 | # Files in SRC_URI are copied directly, anything that's a directory |
| 136 | # (e.g. git repositories) is "unpacked" and then put into a tarball. |
| 137 | python do_ar_original() { |
| 138 | |
Brad Bishop | 37a0e4d | 2017-12-04 01:01:44 -0500 | [diff] [blame] | 139 | import shutil, tempfile |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 140 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 141 | if d.getVarFlag('ARCHIVER_MODE', 'src') != "original": |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 142 | return |
| 143 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 144 | ar_outdir = d.getVar('ARCHIVER_OUTDIR') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 145 | bb.note('Archiving the original source...') |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 146 | urls = d.getVar("SRC_URI").split() |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 147 | # destsuffix (git fetcher) and subdir (everything else) are allowed to be |
| 148 | # absolute paths (for example, destsuffix=${S}/foobar). |
| 149 | # That messes with unpacking inside our tmpdir below, because the fetchers |
| 150 | # will then unpack in that directory and completely ignore the tmpdir. |
| 151 | # That breaks parallel tasks relying on ${S}, like do_compile. |
| 152 | # |
| 153 | # To solve this, we remove these parameters from all URLs. |
| 154 | # We do this even for relative paths because it makes the content of the |
| 155 | # archives more useful (no extra paths that are only used during |
| 156 | # compilation). |
| 157 | for i, url in enumerate(urls): |
| 158 | decoded = bb.fetch2.decodeurl(url) |
| 159 | for param in ('destsuffix', 'subdir'): |
| 160 | if param in decoded[5]: |
| 161 | del decoded[5][param] |
| 162 | encoded = bb.fetch2.encodeurl(decoded) |
| 163 | urls[i] = encoded |
| 164 | fetch = bb.fetch2.Fetch(urls, d) |
| 165 | tarball_suffix = {} |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 166 | for url in fetch.urls: |
| 167 | local = fetch.localpath(url).rstrip("/"); |
| 168 | if os.path.isfile(local): |
| 169 | shutil.copy(local, ar_outdir) |
| 170 | elif os.path.isdir(local): |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 171 | tmpdir = tempfile.mkdtemp(dir=d.getVar('ARCHIVER_WORKDIR')) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 172 | fetch.unpack(tmpdir, (url,)) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 173 | # To handle recipes with more than one source, we add the "name" |
| 174 | # URL parameter as suffix. We treat it as an error when |
| 175 | # there's more than one URL without a name, or a name gets reused. |
| 176 | # This is an additional safety net, in practice the name has |
| 177 | # to be set when using the git fetcher, otherwise SRCREV cannot |
| 178 | # be set separately for each URL. |
| 179 | params = bb.fetch2.decodeurl(url)[5] |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 180 | type = bb.fetch2.decodeurl(url)[0] |
| 181 | location = bb.fetch2.decodeurl(url)[2] |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 182 | name = params.get('name', '') |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 183 | if type.lower() == 'file': |
| 184 | name_tmp = location.rstrip("*").rstrip("/") |
| 185 | name = os.path.basename(name_tmp) |
| 186 | else: |
| 187 | if name in tarball_suffix: |
| 188 | if not name: |
| 189 | bb.fatal("Cannot determine archive names for original source because 'name' URL parameter is unset in more than one URL. Add it to at least one of these: %s %s" % (tarball_suffix[name], url)) |
| 190 | else: |
| 191 | bb.fatal("Cannot determine archive names for original source because 'name=' URL parameter '%s' is used twice. Make it unique in: %s %s" % (tarball_suffix[name], url)) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 192 | tarball_suffix[name] = url |
| 193 | create_tarball(d, tmpdir + '/.', name, ar_outdir) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 194 | |
| 195 | # Emit patch series files for 'original' |
| 196 | bb.note('Writing patch series files...') |
| 197 | for patch in src_patches(d): |
| 198 | _, _, local, _, _, parm = bb.fetch.decodeurl(patch) |
| 199 | patchdir = parm.get('patchdir') |
| 200 | if patchdir: |
| 201 | series = os.path.join(ar_outdir, 'series.subdir.%s' % patchdir.replace('/', '_')) |
| 202 | else: |
| 203 | series = os.path.join(ar_outdir, 'series') |
| 204 | |
| 205 | with open(series, 'a') as s: |
| 206 | s.write('%s -p%s\n' % (os.path.basename(local), parm['striplevel'])) |
| 207 | } |
| 208 | |
| 209 | python do_ar_patched() { |
| 210 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 211 | if d.getVarFlag('ARCHIVER_MODE', 'src') != 'patched': |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 212 | return |
| 213 | |
| 214 | # Get the ARCHIVER_OUTDIR before we reset the WORKDIR |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 215 | ar_outdir = d.getVar('ARCHIVER_OUTDIR') |
| 216 | ar_workdir = d.getVar('ARCHIVER_WORKDIR') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 217 | bb.note('Archiving the patched source...') |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 218 | d.setVar('WORKDIR', ar_workdir) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 219 | create_tarball(d, d.getVar('S'), 'patched', ar_outdir) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 220 | } |
| 221 | |
| 222 | python do_ar_configured() { |
| 223 | import shutil |
| 224 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 225 | # Forcibly expand the sysroot paths as we're about to change WORKDIR |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 226 | d.setVar('STAGING_DIR_HOST', d.getVar('STAGING_DIR_HOST')) |
| 227 | d.setVar('STAGING_DIR_TARGET', d.getVar('STAGING_DIR_TARGET')) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 228 | d.setVar('RECIPE_SYSROOT', d.getVar('RECIPE_SYSROOT')) |
| 229 | d.setVar('RECIPE_SYSROOT_NATIVE', d.getVar('RECIPE_SYSROOT_NATIVE')) |
| 230 | |
| 231 | ar_outdir = d.getVar('ARCHIVER_OUTDIR') |
| 232 | if d.getVarFlag('ARCHIVER_MODE', 'src') == 'configured': |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 233 | bb.note('Archiving the configured source...') |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 234 | pn = d.getVar('PN') |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 235 | # "gcc-source-${PV}" recipes don't have "do_configure" |
| 236 | # task, so we need to run "do_preconfigure" instead |
| 237 | if pn.startswith("gcc-source-"): |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 238 | d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR')) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 239 | bb.build.exec_func('do_preconfigure', d) |
| 240 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 241 | # The libtool-native's do_configure will remove the |
| 242 | # ${STAGING_DATADIR}/aclocal/libtool.m4, so we can't re-run the |
| 243 | # do_configure, we archive the already configured ${S} to |
| 244 | # instead of. |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 245 | elif pn != 'libtool-native': |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 246 | # Change the WORKDIR to make do_configure run in another dir. |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 247 | d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR')) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 248 | if bb.data.inherits_class('kernel-yocto', d): |
| 249 | bb.build.exec_func('do_kernel_configme', d) |
| 250 | if bb.data.inherits_class('cmake', d): |
| 251 | bb.build.exec_func('do_generate_toolchain_file', d) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 252 | prefuncs = d.getVarFlag('do_configure', 'prefuncs') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 253 | for func in (prefuncs or '').split(): |
| 254 | if func != "sysroot_cleansstate": |
| 255 | bb.build.exec_func(func, d) |
| 256 | bb.build.exec_func('do_configure', d) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 257 | postfuncs = d.getVarFlag('do_configure', 'postfuncs') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 258 | for func in (postfuncs or '').split(): |
| 259 | if func != "do_qa_configure": |
| 260 | bb.build.exec_func(func, d) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 261 | srcdir = d.getVar('S') |
| 262 | builddir = d.getVar('B') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 263 | if srcdir != builddir: |
| 264 | if os.path.exists(builddir): |
| 265 | oe.path.copytree(builddir, os.path.join(srcdir, \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 266 | 'build.%s.ar_configured' % d.getVar('PF'))) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 267 | create_tarball(d, srcdir, 'configured', ar_outdir) |
| 268 | } |
| 269 | |
Brad Bishop | c4ea075 | 2018-11-15 14:30:15 -0800 | [diff] [blame] | 270 | def exclude_useless_paths(tarinfo): |
| 271 | if tarinfo.isdir(): |
| 272 | if tarinfo.name.endswith('/temp') or tarinfo.name.endswith('/patches') or tarinfo.name.endswith('/.pc'): |
| 273 | return None |
| 274 | elif tarinfo.name == 'temp' or tarinfo.name == 'patches' or tarinfo.name == '.pc': |
| 275 | return None |
| 276 | return tarinfo |
| 277 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 278 | def create_tarball(d, srcdir, suffix, ar_outdir): |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 279 | """ |
| 280 | create the tarball from srcdir |
| 281 | """ |
| 282 | import tarfile |
| 283 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 284 | # Make sure we are only creating a single tarball for gcc sources |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 285 | if (d.getVar('SRC_URI') == ""): |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 286 | return |
| 287 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 288 | # For the kernel archive, srcdir may just be a link to the |
| 289 | # work-shared location. Use os.path.realpath to make sure |
| 290 | # that we archive the actual directory and not just the link. |
| 291 | srcdir = os.path.realpath(srcdir) |
| 292 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 293 | bb.utils.mkdirhier(ar_outdir) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 294 | if suffix: |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 295 | filename = '%s-%s.tar.gz' % (d.getVar('PF'), suffix) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 296 | else: |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 297 | filename = '%s.tar.gz' % d.getVar('PF') |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 298 | tarname = os.path.join(ar_outdir, filename) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 299 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 300 | bb.note('Creating %s' % tarname) |
| 301 | tar = tarfile.open(tarname, 'w:gz') |
Brad Bishop | c4ea075 | 2018-11-15 14:30:15 -0800 | [diff] [blame] | 302 | tar.add(srcdir, arcname=os.path.basename(srcdir), filter=exclude_useless_paths) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 303 | tar.close() |
| 304 | |
| 305 | # creating .diff.gz between source.orig and source |
| 306 | def create_diff_gz(d, src_orig, src, ar_outdir): |
| 307 | |
| 308 | import subprocess |
| 309 | |
| 310 | if not os.path.isdir(src) or not os.path.isdir(src_orig): |
| 311 | return |
| 312 | |
| 313 | # The diff --exclude can't exclude the file with path, so we copy |
| 314 | # the patched source, and remove the files that we'd like to |
| 315 | # exclude. |
| 316 | src_patched = src + '.patched' |
| 317 | oe.path.copyhardlinktree(src, src_patched) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 318 | for i in d.getVarFlag('ARCHIVER_MODE', 'diff-exclude').split(): |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 319 | bb.utils.remove(os.path.join(src_orig, i), recurse=True) |
| 320 | bb.utils.remove(os.path.join(src_patched, i), recurse=True) |
| 321 | |
| 322 | dirname = os.path.dirname(src) |
| 323 | basename = os.path.basename(src) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 324 | bb.utils.mkdirhier(ar_outdir) |
| 325 | cwd = os.getcwd() |
| 326 | try: |
| 327 | os.chdir(dirname) |
| 328 | out_file = os.path.join(ar_outdir, '%s-diff.gz' % d.getVar('PF')) |
| 329 | diff_cmd = 'diff -Naur %s.orig %s.patched | gzip -c > %s' % (basename, basename, out_file) |
| 330 | subprocess.check_call(diff_cmd, shell=True) |
| 331 | bb.utils.remove(src_patched, recurse=True) |
| 332 | finally: |
| 333 | os.chdir(cwd) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 334 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 335 | def is_work_shared(d): |
| 336 | pn = d.getVar('PN') |
| 337 | return bb.data.inherits_class('kernel', d) or pn.startswith('gcc-source') |
| 338 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 339 | # Run do_unpack and do_patch |
| 340 | python do_unpack_and_patch() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 341 | if d.getVarFlag('ARCHIVER_MODE', 'src') not in \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 342 | [ 'patched', 'configured'] and \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 343 | d.getVarFlag('ARCHIVER_MODE', 'diff') != '1': |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 344 | return |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 345 | ar_outdir = d.getVar('ARCHIVER_OUTDIR') |
| 346 | ar_workdir = d.getVar('ARCHIVER_WORKDIR') |
| 347 | ar_sysroot_native = d.getVar('STAGING_DIR_NATIVE') |
| 348 | pn = d.getVar('PN') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 349 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 350 | # The kernel class functions require it to be on work-shared, so we dont change WORKDIR |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 351 | if not is_work_shared(d): |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 352 | # Change the WORKDIR to make do_unpack do_patch run in another dir. |
| 353 | d.setVar('WORKDIR', ar_workdir) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 354 | # Restore the original path to recipe's native sysroot (it's relative to WORKDIR). |
| 355 | d.setVar('STAGING_DIR_NATIVE', ar_sysroot_native) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 356 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 357 | # The changed 'WORKDIR' also caused 'B' changed, create dir 'B' for the |
| 358 | # possibly requiring of the following tasks (such as some recipes's |
| 359 | # do_patch required 'B' existed). |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 360 | bb.utils.mkdirhier(d.getVar('B')) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 361 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 362 | bb.build.exec_func('do_unpack', d) |
| 363 | |
| 364 | # Save the original source for creating the patches |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 365 | if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1': |
| 366 | src = d.getVar('S').rstrip('/') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 367 | src_orig = '%s.orig' % src |
| 368 | oe.path.copytree(src, src_orig) |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 369 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 370 | # Make sure gcc and kernel sources are patched only once |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 371 | if not (d.getVar('SRC_URI') == "" or is_work_shared(d)): |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 372 | bb.build.exec_func('do_patch', d) |
| 373 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 374 | # Create the patches |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 375 | if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1': |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 376 | bb.note('Creating diff gz...') |
| 377 | create_diff_gz(d, src_orig, src, ar_outdir) |
| 378 | bb.utils.remove(src_orig, recurse=True) |
| 379 | } |
| 380 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 381 | # BBINCLUDED is special (excluded from basehash signature |
| 382 | # calculation). Using it in a task signature can cause "basehash |
| 383 | # changed" errors. |
| 384 | # |
| 385 | # Depending on BBINCLUDED also causes do_ar_recipe to run again |
| 386 | # for unrelated changes, like adding or removing buildhistory.bbclass. |
| 387 | # |
| 388 | # For these reasons we ignore the dependency completely. The versioning |
| 389 | # of the output file ensures that we create it each time the recipe |
| 390 | # gets rebuilt, at least as long as a PR server is used. We also rely |
| 391 | # on that mechanism to catch changes in the file content, because the |
| 392 | # file content is not part of of the task signature either. |
| 393 | do_ar_recipe[vardepsexclude] += "BBINCLUDED" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 394 | python do_ar_recipe () { |
| 395 | """ |
| 396 | archive the recipe, including .bb and .inc. |
| 397 | """ |
| 398 | import re |
| 399 | import shutil |
| 400 | |
| 401 | require_re = re.compile( r"require\s+(.+)" ) |
| 402 | include_re = re.compile( r"include\s+(.+)" ) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 403 | bbfile = d.getVar('FILE') |
| 404 | outdir = os.path.join(d.getVar('WORKDIR'), \ |
| 405 | '%s-recipe' % d.getVar('PF')) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 406 | bb.utils.mkdirhier(outdir) |
| 407 | shutil.copy(bbfile, outdir) |
| 408 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 409 | pn = d.getVar('PN') |
| 410 | bbappend_files = d.getVar('BBINCLUDED').split() |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 411 | # If recipe name is aa, we need to match files like aa.bbappend and aa_1.1.bbappend |
| 412 | # Files like aa1.bbappend or aa1_1.1.bbappend must be excluded. |
Brad Bishop | 37a0e4d | 2017-12-04 01:01:44 -0500 | [diff] [blame] | 413 | bbappend_re = re.compile( r".*/%s_[^/]*\.bbappend$" % re.escape(pn)) |
| 414 | bbappend_re1 = re.compile( r".*/%s\.bbappend$" % re.escape(pn)) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 415 | for file in bbappend_files: |
| 416 | if bbappend_re.match(file) or bbappend_re1.match(file): |
| 417 | shutil.copy(file, outdir) |
| 418 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 419 | dirname = os.path.dirname(bbfile) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 420 | bbpath = '%s:%s' % (dirname, d.getVar('BBPATH')) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 421 | f = open(bbfile, 'r') |
| 422 | for line in f.readlines(): |
| 423 | incfile = None |
| 424 | if require_re.match(line): |
| 425 | incfile = require_re.match(line).group(1) |
| 426 | elif include_re.match(line): |
| 427 | incfile = include_re.match(line).group(1) |
| 428 | if incfile: |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 429 | incfile = d.expand(incfile) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 430 | incfile = bb.utils.which(bbpath, incfile) |
| 431 | if incfile: |
| 432 | shutil.copy(incfile, outdir) |
| 433 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 434 | create_tarball(d, outdir, 'recipe', d.getVar('ARCHIVER_OUTDIR')) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 435 | bb.utils.remove(outdir, recurse=True) |
| 436 | } |
| 437 | |
| 438 | python do_dumpdata () { |
| 439 | """ |
| 440 | dump environment data to ${PF}-showdata.dump |
| 441 | """ |
| 442 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 443 | dumpfile = os.path.join(d.getVar('ARCHIVER_OUTDIR'), \ |
| 444 | '%s-showdata.dump' % d.getVar('PF')) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 445 | bb.note('Dumping metadata into %s' % dumpfile) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 446 | with open(dumpfile, "w") as f: |
| 447 | # emit variables and shell functions |
| 448 | bb.data.emit_env(f, d, True) |
| 449 | # emit the metadata which isn't valid shell |
| 450 | for e in d.keys(): |
| 451 | if d.getVarFlag(e, "python", False): |
| 452 | f.write("\npython %s () {\n%s}\n" % (e, d.getVar(e, False))) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 453 | } |
| 454 | |
| 455 | SSTATETASKS += "do_deploy_archives" |
| 456 | do_deploy_archives () { |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 457 | echo "Deploying source archive files from ${ARCHIVER_TOPDIR} to ${DEPLOY_DIR_SRC}." |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 458 | } |
| 459 | python do_deploy_archives_setscene () { |
| 460 | sstate_setscene(d) |
| 461 | } |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 462 | do_deploy_archives[dirs] = "${ARCHIVER_TOPDIR}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 463 | do_deploy_archives[sstate-inputdirs] = "${ARCHIVER_TOPDIR}" |
| 464 | do_deploy_archives[sstate-outputdirs] = "${DEPLOY_DIR_SRC}" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 465 | addtask do_deploy_archives_setscene |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 466 | |
| 467 | addtask do_ar_original after do_unpack |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 468 | addtask do_unpack_and_patch after do_patch |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 469 | addtask do_ar_patched after do_unpack_and_patch |
| 470 | addtask do_ar_configured after do_unpack_and_patch |
| 471 | addtask do_dumpdata |
| 472 | addtask do_ar_recipe |
| 473 | addtask do_deploy_archives before do_build |
| 474 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 475 | python () { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 476 | # Add tasks in the correct order, specifically for linux-yocto to avoid race condition. |
| 477 | # sstatesig.py:sstate_rundepfilter has special support that excludes this dependency |
| 478 | # so that do_kernel_configme does not need to run again when do_unpack_and_patch |
| 479 | # gets added or removed (by adding or removing archiver.bbclass). |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 480 | if bb.data.inherits_class('kernel-yocto', d): |
| 481 | bb.build.addtask('do_kernel_configme', 'do_configure', 'do_unpack_and_patch', d) |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 482 | } |