Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | do_install() { |
| 2 | oe_runmake install_root=${D} install |
| 3 | for r in ${rpcsvc}; do |
| 4 | h=`echo $r|sed -e's,\.x$,.h,'` |
| 5 | install -m 0644 ${S}/sunrpc/rpcsvc/$h ${D}/${includedir}/rpcsvc/ |
| 6 | done |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 7 | install -Dm 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/ld.so.conf |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 8 | install -d ${D}${localedir} |
| 9 | make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED" |
| 10 | # get rid of some broken files... |
| 11 | for i in ${GLIBC_BROKEN_LOCALES}; do |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 12 | sed -i "/$i/d" ${WORKDIR}/SUPPORTED |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | done |
| 14 | rm -f ${D}${sysconfdir}/rpc |
| 15 | rm -rf ${D}${datadir}/zoneinfo |
| 16 | rm -rf ${D}${libexecdir}/getconf |
| 17 | } |
| 18 | |
| 19 | def get_libc_fpu_setting(bb, d): |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 20 | if d.getVar('TARGET_FPU') in [ 'soft', 'ppc-efd' ]: |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 21 | return "--without-fp" |
| 22 | return "" |
| 23 | |
| 24 | python populate_packages_prepend () { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 25 | if d.getVar('DEBIAN_NAMES'): |
| 26 | pkgs = d.getVar('PACKAGES').split() |
| 27 | bpn = d.getVar('BPN') |
| 28 | prefix = d.getVar('MLPREFIX') or "" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 29 | # Set the base package... |
| 30 | d.setVar('PKG_' + prefix + bpn, prefix + 'libc6') |
| 31 | libcprefix = prefix + bpn + '-' |
| 32 | for p in pkgs: |
| 33 | # And all the subpackages. |
| 34 | if p.startswith(libcprefix): |
| 35 | renamed = p.replace(bpn, 'libc6', 1) |
| 36 | d.setVar('PKG_' + p, renamed) |
| 37 | # For backward compatibility with old -dbg package |
| 38 | d.appendVar('RPROVIDES_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg') |
| 39 | d.appendVar('RCONFLICTS_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg') |
| 40 | d.appendVar('RREPLACES_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg') |
| 41 | } |