Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | |
| 2 | inherit python-dir |
| 3 | |
| 4 | PYTHON="${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN}" |
| 5 | # PYTHON_EXECUTABLE is used by cmake |
| 6 | PYTHON_EXECUTABLE="${PYTHON}" |
| 7 | EXTRANATIVEPATH += "${PYTHON_PN}-native" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 8 | DEPENDS_append = " ${PYTHON_PN}-native " |
| 9 | |
| 10 | # python-config and other scripts are using distutils modules |
| 11 | # which we patch to access these variables |
| 12 | export STAGING_INCDIR |
| 13 | export STAGING_LIBDIR |
| 14 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 15 | # suppress host user's site-packages dirs. |
| 16 | export PYTHONNOUSERSITE = "1" |
| 17 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 18 | # autoconf macros will use their internal default preference otherwise |
| 19 | export PYTHON |