Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Key/value database library with extensible hashing" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/gdbm/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d8e20eece214df8ef953ed5857862150" |
| 6 | |
| 7 | PR = "r4" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \ |
| 10 | file://makefile.patch \ |
| 11 | file://libtool-mode.patch \ |
| 12 | file://ldflags.patch" |
| 13 | |
| 14 | SRC_URI[md5sum] = "1d1b1d5c0245b1c00aff92da751e9aa1" |
| 15 | SRC_URI[sha256sum] = "cc340338a2e28b40058ab9eb5354a21d53f88a1582ea21ba0bb185c37a281dc9" |
| 16 | |
| 17 | inherit autotools texinfo |
| 18 | |
| 19 | BBCLASSEXTEND = "native nativesdk" |
| 20 | |
| 21 | do_install_append () { |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 22 | oe_runmake install-compat DESTDIR=${D} |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 23 | install -d ${D}${includedir}/gdbm |
| 24 | install -m 0644 ${S}/dbm.h ${D}${includedir}/ |
| 25 | install -m 0644 ${S}/ndbm.h ${D}${includedir}/ |
| 26 | # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find |
| 27 | # these headers |
| 28 | ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h |
| 29 | ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h |
| 30 | } |