Andre McCurdy | 1ea3f66 | 2016-12-15 06:11:31 -0800 | [diff] [blame] | 1 | DESCRIPTION = "Google's framework for writing C++ tests" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 2 | HOMEPAGE = "https://github.com/google/googletest" |
Andre McCurdy | 1ea3f66 | 2016-12-15 06:11:31 -0800 | [diff] [blame] | 3 | SECTION = "libs" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \ |
| 6 | file://googletest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a" |
| 7 | |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 8 | PV = "1.10.0" |
| 9 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 10 | PROVIDES += "gmock gtest" |
Andre McCurdy | 1ea3f66 | 2016-12-15 06:11:31 -0800 | [diff] [blame] | 11 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | S = "${WORKDIR}/git" |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 13 | SRCREV = "703bd9caab50b139428cea1aaff9974ebee5742e" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 14 | SRC_URI = "git://github.com/google/googletest.git" |
Andre McCurdy | 1ea3f66 | 2016-12-15 06:11:31 -0800 | [diff] [blame] | 15 | |
Andre McCurdy | 1ea3f66 | 2016-12-15 06:11:31 -0800 | [diff] [blame] | 16 | inherit cmake |
| 17 | |
| 18 | ALLOW_EMPTY_${PN} = "1" |
| 19 | ALLOW_EMPTY_${PN}-dbg = "1" |
| 20 | |
| 21 | RDEPENDS_${PN}-dev += "${PN}-staticdev" |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 24 | |
| 25 | do_configure_prepend() { |
| 26 | # explicitly use python3 |
| 27 | # the scripts are already python3 compatible since https://github.com/google/googletest/commit/d404af0d987a9c38cafce82a7e26ec8468c88361 and other fixes like this |
| 28 | # but since this oe-core change http://git.openembedded.org/openembedded-core/commit/?id=5f8f16b17f66966ae91aeabc23e97de5ecd17447 |
| 29 | # there isn't python in HOSTTOOLS so "env python" fails |
| 30 | sed -i 's@^#!/usr/bin/env python$@#!/usr/bin/env python3@g' ${S}/googlemock/scripts/*py ${S}/googlemock/scripts/generator/*py ${S}/googlemock/scripts/generator/cpp/*py ${S}/googlemock/test/*py ${S}/googletest/scripts/*py ${S}/googletest/test/*py |
| 31 | } |