Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Synergy - control multiple computers with one keyboard and mouse" |
| 2 | HOMEPAGE = "http://synergy-project.org" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2ba51ca68e055566aade24662f9eb41" |
| 4 | LICENSE = "GPL-2.0-with-OpenSSL-exception" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 5 | SECTION = "x11/utils" |
| 6 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | DEPENDS = "virtual/libx11 libxtst libxinerama curl openssl" |
| 8 | do_unpack_extra[depends] = "unzip-native:do_populate_sysroot" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 9 | |
| 10 | # depends on virtual/libx11 |
| 11 | REQUIRED_DISTRO_FEATURES = "x11" |
| 12 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | SRC_URI = "git://github.com/symless/synergy.git;protocol=http" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 14 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 15 | # Version 1.8.8-stable |
| 16 | SRCREV ?= "c30301e23424db1125664da17deb8c3aa6aec52d" |
| 17 | PV = "1.8.8+${SRCPV}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit cmake distro_features_check |
| 22 | |
| 23 | do_unpack_extra() { |
| 24 | cd ${S}/ext |
| 25 | for file in *.zip; do |
| 26 | fname="${file##*/}" |
| 27 | unzip $file -d ${fname%.*} |
| 28 | done |
| 29 | } |
| 30 | addtask unpack_extra after do_unpack before do_patch |
| 31 | |
| 32 | do_install() { |
| 33 | install -d ${D}/usr/bin |
| 34 | install -m 0755 ${S}/bin/synergy* ${D}/usr/bin/ |
| 35 | } |