Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "PIP is a tool for installing and managing Python packages" |
| 2 | HOMEPAGE = "https://pip.pypa.io/" |
| 3 | LICENSE = "MIT & LGPL-2.1" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e" |
| 5 | |
Brad Bishop | ba6de43 | 2019-05-21 08:07:33 -0400 | [diff] [blame] | 6 | SRC_URI[md5sum] = "4fb98a060f21c731d6743b90a714fc73" |
| 7 | SRC_URI[sha256sum] = "44d3d7d3d30a1eb65c7e5ff1173cdf8f7467850605ac7cc3707b6064bddd0958" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | |
| 9 | inherit pypi setuptools |
| 10 | |
| 11 | # Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works |
| 12 | RDEPENDS_${PN}_class-target = "python-modules python-distribute python-misc" |
| 13 | |
| 14 | BBCLASSEXTEND = "native nativesdk" |