Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Python bindings for the DBus inter-process communication system" |
| 2 | SECTION = "devel/python" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4" |
| 6 | DEPENDS = "expat dbus dbus-glib virtual/libintl" |
| 7 | |
| 8 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \ |
| 9 | " |
| 10 | |
| 11 | RSRC_URI[md5sum] = "1ce1ddf2582060f8f971652ea54cc17e" |
| 12 | SRC_URI[sha256sum] = "32f29c17172cdb9cb61c68b1f1a71dfe7351506fc830869029c47449bd04faeb" |
| 13 | S = "${WORKDIR}/dbus-python-${PV}" |
| 14 | |
| 15 | inherit distutils3-base autotools pkgconfig |
| 16 | |
| 17 | PACKAGECONFIG ?= "" |
| 18 | PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python3-docutils-native" |
| 19 | PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python3-docutils-native python3-epydoc-native" |
| 20 | |
| 21 | RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml" |
| 22 | |
| 23 | FILES_${PN}-dev += "${libdir}/pkgconfig" |