Patrick Williams | 8dd6848 | 2022-10-04 07:57:18 -0500 | [diff] [blame] | 1 | SUMMARY = "External system Cortex-M3 Firmware" |
| 2 | DESCRIPTION = "Firmware to be loaded and run in External System Harness in\ |
| 3 | support to the main application CPU." |
| 4 | HOMEPAGE = "https://git.linaro.org/landing-teams/working/arm/external-system.git" |
| 5 | DEPENDS = "gcc-arm-none-eabi-native" |
| 6 | INHIBIT_DEFAULT_DEPS="1" |
| 7 | LICENSE = "BSD-3-Clause & Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://license.md;md5=e44b2531cd6ffe9dece394dbe988d9a0 \ |
| 9 | file://cmsis/LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 10 | |
Andrew Geissler | 9347dd4 | 2023-03-03 12:38:41 -0600 | [diff] [blame] | 11 | SRC_URI = "gitsm://git.gitlab.arm.com/arm-reference-solutions/corstone1000/external_system/rtx.git;protocol=https;branch=master \ |
Andrew Geissler | 2edf064 | 2023-09-11 08:24:07 -0400 | [diff] [blame] | 12 | file://0001-tools-gen_module_code-atomically-rewrite-the-generat.patch" |
Patrick Williams | 8dd6848 | 2022-10-04 07:57:18 -0500 | [diff] [blame] | 13 | SRCREV = "8c9dca74b104ff6c9722fb0738ba93dd3719c080" |
Andrew Geissler | 2edf064 | 2023-09-11 08:24:07 -0400 | [diff] [blame] | 14 | PV .= "+git" |
Patrick Williams | 8dd6848 | 2022-10-04 07:57:18 -0500 | [diff] [blame] | 15 | |
| 16 | COMPATIBLE_MACHINE = "(corstone1000)" |
Andrew Geissler | 2edf064 | 2023-09-11 08:24:07 -0400 | [diff] [blame] | 17 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
Patrick Williams | 8dd6848 | 2022-10-04 07:57:18 -0500 | [diff] [blame] | 18 | |
| 19 | # PRODUCT is passed to the Makefile to specify the platform to be used. |
| 20 | PRODUCT = "corstone-1000" |
| 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | B = "${WORKDIR}/build" |
| 24 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 25 | # remove once arm-none-eabi-gcc updates to 13 or newer like poky |
| 26 | DEBUG_PREFIX_MAP:remove = "-fcanon-prefix-map" |
| 27 | |
Patrick Williams | 8dd6848 | 2022-10-04 07:57:18 -0500 | [diff] [blame] | 28 | LDFLAGS[unexport] = "1" |
| 29 | |
| 30 | do_compile() { |
| 31 | oe_runmake -C ${S} V=y \ |
| 32 | BUILD_PATH=${B} \ |
| 33 | PRODUCT=${PRODUCT} \ |
| 34 | CROSS_COMPILE=arm-none-eabi- \ |
| 35 | all |
| 36 | } |
| 37 | |
| 38 | do_compile[cleandirs] = "${B}" |
| 39 | |
| 40 | do_install() { |
| 41 | install -D -p -m 0644 ${B}/product/${PRODUCT}/firmware/release/bin/firmware.bin ${D}/firmware/es_flashfw.bin |
| 42 | } |
| 43 | |
| 44 | FILES:${PN} = "/firmware" |
| 45 | SYSROOT_DIRS += "/firmware" |
| 46 | |
| 47 | inherit deploy |
| 48 | |
| 49 | do_deploy() { |
| 50 | cp -rf ${D}/firmware/* ${DEPLOYDIR}/ |
| 51 | } |
| 52 | addtask deploy after do_install |