blob: bf8a1225390713ec8c93469c7a06be0fb5a3bf35 [file] [log] [blame]
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -05001SUMMARY = "OpenPower Software Management"
2DESCRIPTION = "OpenPower Software Manager provides a set of host software \
3management daemons. It is suitable for use on a wide variety of OpenPower \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/openpower-pnor-code-mgmt"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10inherit autotools pkgconfig
11inherit obmc-phosphor-dbus-service
12
13DEPENDS += " \
14 autoconf-archive-native \
15 phosphor-dbus-interfaces \
16 phosphor-logging \
17 sdbusplus \
18 "
19
20RDEPENDS_${PN} += " \
21 mtd-utils-ubifs \
22 phosphor-dbus-interfaces \
23 phosphor-logging \
24 sdbusplus \
25 "
26
27DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
28SYSTEMD_SERVICE_${PN} += " \
29 obmc-flash-bios-ubiattach.service \
30 obmc-flash-bios-ubimount@.service \
Adriana Kobylak7f01f212017-05-22 14:41:02 -050031 obmc-flash-bios-ubiumount-prsv.service \
32 obmc-flash-bios-ubiumount-rw@.service \
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050033 obmc-flash-bios-squashfsmount@.service \
34 "
35
36SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
Patrick Williams313b7b22017-05-31 09:50:02 -050037SRCREV = "3accb3221efd3cfc7d409438bee5a1801c2561dc"
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050038
39S = "${WORKDIR}/git"