blob: 8fbe1fa91fe7383660e65ae5484dcda3ee04ea82 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
7
8inherit pypi setuptools3
9
10DEPENDS += "${PYTHON_PN}-grpcio"
11
12SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
13 file://0001-protobuf-Disable-musttail-attribute-on-mips.patch \
Andrew Geissler8f840682023-07-21 09:09:43 -050014 file://0001-direct_mmap-Use-off_t-on-linux.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060015 "
Andrew Geissler8f840682023-07-21 09:09:43 -050016SRC_URI[sha256sum] = "39f5877cea514b3da9f2683dfb3ffb45ef47b05f4ff39c287d7d61c5057f48b8"
Andrew Geissler517393d2023-01-13 08:55:19 -060017
18RDEPENDS:${PN} = "${PYTHON_PN}-grpcio"
19
20BBCLASSEXTEND = "native nativesdk"