blob: d05c7f49275e47622bd8aec10ebe9a3b613b3dae [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001# SPDX-License-Identifier: MIT
2# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "A tool for creating isolated virtual python environments."
5HOMEPAGE = "https://github.com/pypa/virtualenv"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=0ce089158cf60a8ab6abb452b6405538"
8
Andrew Geissler220dafd2023-10-04 10:18:08 -05009SRC_URI[sha256sum] = "e8361967f6da6fbdf1426483bfe9fca8287c242ac0bc30429905721cefbff752"
Andrew Geissler8f840682023-07-21 09:09:43 -050010
11BBCLASSEXTEND = "native nativesdk"
12inherit pypi python_hatchling
13
14DEPENDS += "\
15 ${PYTHON_PN}-hatch-vcs-native \
16"
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-distlib \
20 ${PYTHON_PN}-filelock \
21 ${PYTHON_PN}-platformdirs \
22"