Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "OCI systemd hook enables users to run systemd in docker and OCI" |
| 2 | SECTION = "console/utils" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504" |
| 5 | PRIORITY = "optional" |
| 6 | |
| 7 | DEPENDS = "yajl util-linux" |
| 8 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | SRCREV = "1ac958a4197a9ea52174812fc7d7d036af8140d3" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 10 | SRC_URI = "git://github.com/projectatomic/oci-systemd-hook \ |
| 11 | file://0001-selinux-drop-selinux-support.patch \ |
| 12 | file://0001-configure-drop-selinux-support.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame^] | 13 | file://0001-Add-additional-cgroup-mounts-from-root-NS-automatica.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 14 | " |
| 15 | |
| 16 | PV = "0.0.1+git${SRCPV}" |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit autotools pkgconfig |
| 20 | |
| 21 | PACKAGECONFIG ??= "" |
| 22 | PACKAGECONFIG[selinux] = ",,libselinux" |
| 23 | |
| 24 | EXTRA_OECONF += "--libexecdir=${libexecdir}/oci/hooks.d" |
| 25 | |
| 26 | # nothing to compile, we do it all in the install task |
| 27 | do_compile[noexec] = "1" |
| 28 | |
| 29 | do_install() { |
| 30 | # Avoid building docs, and other artifacts by surgically calling the |
| 31 | # semi-internal target of "install-exec-am" |
| 32 | oe_runmake 'DESTDIR=${D}' install-exec-am |
| 33 | } |
| 34 | |
| 35 | FILES_${PN} += "${libexecdir}/oci/hooks.d/" |
| 36 | |