blob: c7b8b2933c78e77f1bd9cc9611d3e84485349f8b [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Precision Time Protocol (PTP) according to IEEE standard 1588 for Linux"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \
6 file://build-Allow-CC-and-prefix-to-be-overriden.patch \
7 file://no-incdefs-using-host-headers.patch \
8 file://0003-include-missing-time.h-for-time_t.patch \
9 file://0004-Adjust-include-header-sequence-to-avoid-duplicate-de.patch \
10 "
11
12SRC_URI[md5sum] = "5688cdfe57932273e1dbf35b3b97b9a0"
13SRC_URI[sha256sum] = "fa8e00f6ec73cefa7bb313dce7f60dfe5eb9e2bde3353594e9ac18edc93e5165"
14
15EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} \
16 EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_POSIX_SPAWN -DHAVE_ONESTEP_SYNC ${CFLAGS}'"
17
18do_install () {
19 install -d ${D}/${bindir}
20 install -p ${S}/ptp4l ${D}/${bindir}
21 install -p ${S}/pmc ${D}/${bindir}
22 install -p ${S}/phc2sys ${D}/${bindir}
23 install -p ${S}/hwstamp_ctl ${D}/${bindir}
24}