Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 1 | SUMMARY = "cpulimit is a tool which limits the CPU usage of a process" |
| 2 | HOMEPAGE = "http://cpulimit.sourceforge.net" |
| 3 | LICENSE = "GPL-2.0-or-later" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86c1c0d961a437e529db93aa3bb32dc4" |
| 5 | SRCREV ?= "f4d2682804931e7aea02a869137344bb5452a3cd" |
| 6 | |
| 7 | SRC_URI = "git://g...@github.com/opsengine/cpulimit.git;protocol=https;branch=master \ |
| 8 | file://0001-Remove-sys-sysctl.h-and-add-missing-libgen.h-include.patch \ |
| 9 | " |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | do_compile() { |
| 14 | oe_runmake all |
| 15 | } |
| 16 | do_install() { |
| 17 | install -d ${D}${sbindir} |
| 18 | install -m 0755 ${B}/src/${PN} ${D}${sbindir}/ |
| 19 | } |
| 20 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 21 | CFLAGS += "-D_GNU_SOURCE ${LDFLAGS}" |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 22 | |