Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "System performance benchmark" |
| 2 | HOMEPAGE = "http://github.com/akopytov/sysbench" |
| 3 | SECTION = "console/tests" |
| 4 | LICENSE = "GPL-2.0-only" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | DEPENDS = "libtool libaio luajit concurrencykit" |
| 8 | |
| 9 | inherit autotools-brokensep pkgconfig |
| 10 | |
| 11 | # The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from |
| 12 | # Launchpad until the next release is available from Github. |
| 13 | SRC_URI = "git://github.com/akopytov/sysbench.git;protocol=https;branch=master" |
| 14 | SRCREV = "ebf1c90da05dea94648165e4f149abc20c979557" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64).*-linux*" |
| 19 | |
| 20 | EXTRA_OECONF += "--enable-largefile --with-system-luajit --with-system-ck --without-gcc-arch" |
| 21 | PACKAGECONFIG ??= "" |
| 22 | PACKAGECONFIG[aio] = "--enable-aio,--disable-aio,libaio," |
| 23 | PACKAGECONFIG[mysql] = "--with-mysql \ |
| 24 | --with-mysql-includes=${STAGING_INCDIR}/mysql \ |
| 25 | --with-mysql-libs=${STAGING_LIBDIR}, \ |
| 26 | --without-mysql,mysql5" |
| 27 | |
| 28 | do_configure:prepend() { |
| 29 | touch ${S}/NEWS ${S}/AUTHORS |
| 30 | } |