Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Pattern matching utilities" |
| 2 | DESCRIPTION = "The GNU versions of commonly used grep utilities. The grep command searches one or more input \ |
| 3 | files for lines containing a match to a specified pattern." |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" |
| 7 | |
| 8 | PR = "r2" |
| 9 | |
| 10 | SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \ |
| 11 | file://uclibc-fix.patch \ |
| 12 | file://grep_fix_for_automake-1.12.patch \ |
| 13 | file://gettext.patch \ |
| 14 | file://fix64-int-to-pointer.patch \ |
| 15 | file://Makevars \ |
| 16 | file://grep-CVE-2012-5667.patch \ |
| 17 | file://fix-for-texinfo-5.1.patch \ |
| 18 | file://grep-egrep-fgrep-Fix-LSB-NG-cases.patch \ |
| 19 | " |
| 20 | |
| 21 | SRC_URI[md5sum] = "52202fe462770fa6be1bb667bd6cf30c" |
| 22 | SRC_URI[sha256sum] = "38c8a2bb9223d1fb1b10bdd607cf44830afc92fd451ac4cd07619bf92bdd3132" |
| 23 | |
| 24 | inherit autotools gettext texinfo |
| 25 | |
| 26 | EXTRA_OECONF_INCLUDED_REGEX = "--without-included-regex" |
| 27 | EXTRA_OECONF_INCLUDED_REGEX_libc-musl = "--with-included-regex" |
| 28 | |
| 29 | EXTRA_OECONF = "--disable-perl-regexp \ |
| 30 | ${EXTRA_OECONF_INCLUDED_REGEX}" |
| 31 | |
| 32 | CFLAGS += "-D PROTOTYPES" |
| 33 | do_configure_prepend () { |
| 34 | rm -f ${S}/m4/init.m4 |
| 35 | cp -f ${WORKDIR}/Makevars ${S}/po/ |
| 36 | } |
| 37 | |
| 38 | do_install () { |
| 39 | autotools_do_install |
| 40 | install -d ${D}${base_bindir} |
| 41 | mv ${D}${bindir}/grep ${D}${base_bindir}/grep |
| 42 | mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep |
| 43 | mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep |
| 44 | rmdir ${D}${bindir}/ |
| 45 | } |
| 46 | |
| 47 | inherit update-alternatives |
| 48 | |
| 49 | ALTERNATIVE_PRIORITY = "100" |
| 50 | |
| 51 | ALTERNATIVE_${PN} = "grep egrep fgrep" |
| 52 | ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep" |
| 53 | ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep" |
| 54 | ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep" |
| 55 | |
| 56 | export CONFIG_SHELL="/bin/sh" |