Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | DEPENDS = "libusb-compat libftdi" |
| 5 | RDEPENDS_${PN} = "libusb1" |
| 6 | |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 7 | SRC_URI = " \ |
| 8 | git://repo.or.cz/openocd.git;protocol=http;name=openocd \ |
| 9 | git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \ |
| 10 | git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \ |
| 11 | git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 14 | SRCREV_FORMAT = "openocd" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame^] | 15 | SRCREV_openocd = "f342aac0845a69d591ad39a025d74e9c765f6420" |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 16 | SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 17 | SRCREV_jimtcl = "0aa0fb4e3a38d38a49de9eb585d93d63a370dcf6" |
| 18 | SRCREV_libjaylink = "9aa7a5957c07bb6e862fc1a6d3153d109c7407e4" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 19 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame^] | 20 | PV = "0.11+gitr${SRCPV}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit pkgconfig autotools-brokensep gettext |
| 24 | |
Brad Bishop | 2f97392 | 2019-11-11 07:58:48 -0500 | [diff] [blame] | 25 | BBCLASSEXTEND += "native nativesdk" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 26 | |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 27 | EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html --disable-werror" |
| 28 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 29 | do_configure() { |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 30 | ./bootstrap nosubmodule |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/jimtcl/autosetup |
| 32 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/jimtcl/autosetup |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 33 | oe_runconf ${EXTRA_OECONF} |
| 34 | } |
| 35 | |
| 36 | do_install() { |
| 37 | oe_runmake DESTDIR=${D} install |
| 38 | if [ -e "${D}${infodir}" ]; then |
| 39 | rm -Rf ${D}${infodir} |
| 40 | fi |
| 41 | if [ -e "${D}${mandir}" ]; then |
| 42 | rm -Rf ${D}${mandir} |
| 43 | fi |
| 44 | if [ -e "${D}${bindir}/.debug" ]; then |
| 45 | rm -Rf ${D}${bindir}/.debug |
| 46 | fi |
| 47 | } |
| 48 | |
| 49 | FILES_${PN} = " \ |
| 50 | ${datadir}/openocd/* \ |
| 51 | ${bindir}/openocd \ |
| 52 | " |
| 53 | |
| 54 | PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 55 | PACKAGECONFIG[remote-bitbang] = "--enable-remote-bitbang,--disable-remote-bitbang" |
| 56 | PACKAGECONFIG ??= "sysfsgpio remote-bitbang" |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 57 | |
| 58 | # Can't be built with ccache |
| 59 | CCACHE_DISABLE = "1" |