blob: 70e67a1a7e5480b0d8f2293dd3322b14f8db7390 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A Python library for building configuration shells"
2DESCRIPTION = "configshell-fb is a Python library that provides a framework for \
3building simple but nice CLI-based applications. This runs with Python 2 and \
42to3 is run by setup.py to run on Python 3."
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=1dece7821bf3fd70fe1309eaa37d52a2"
8
9SRC_URI = "git://github.com/open-iscsi/configshell-fb.git;protocol=https;branch=master"
Andrew Geissler32b11992021-03-31 13:37:05 -050010SRCREV = "d74a33b69f688ed9b8b28033835303604639d4eb"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12S = "${WORKDIR}/git"
13
14inherit setuptools3
15
16RDEPENDS_${PN} += "python3-modules python3-fcntl python3-six"