blob: 3ef75d47037b2bc5bdacfec7c2150a0172ddf6c5 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Extensible memoizing collections and decorators"
2HOMEPAGE = "https://github.com/tkem/cachetools"
3DESCRIPTION = "This module provides various memoizing \
4collections and decorators, including variants of the \
5Python 3 Standard Library @lru_cache function decorator."
6SECTION = "devel/python"
7
8LICENSE = "MIT"
Patrick Williams03514f12024-04-05 07:04:11 -05009LIC_FILES_CHKSUM = "file://LICENSE;md5=539275e657c6b7af026bb908356f7541"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060010
11inherit pypi python_setuptools_build_meta ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060018 python3-math \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060019"
20
21RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060022 python3-pytest \
23 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060024"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}
30
Patrick Williams03514f12024-04-05 07:04:11 -050031SRC_URI[sha256sum] = "ba29e2dfa0b8b556606f097407ed1aa62080ee108ab0dc5ec9d6a723a007d105"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060032
33BBCLASSEXTEND = "native nativesdk"